media-sound/lollypop: Version bump 1.2.32
authorJohannes Huber <johu@gentoo.org>
Tue, 31 Mar 2020 14:11:01 +0000 (16:11 +0200)
committerJohannes Huber <johu@gentoo.org>
Tue, 31 Mar 2020 14:11:52 +0000 (16:11 +0200)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Johannes Huber <johu@gentoo.org>
media-sound/lollypop/Manifest
media-sound/lollypop/lollypop-1.2.32.ebuild [new file with mode: 0644]

index b08e36354194e32fbd9f2bcbc4c10bc2624cf71b..f97bdfdfacb5ff31847912d1497e8d21aa406c81 100644 (file)
@@ -1,2 +1,3 @@
 DIST lollypop-1.1.4.16.tar.xz 455312 BLAKE2B 358fae45a4332c10ba59d65d09ae51f28fb7fc026e137289c47951536753796e0b7efa9f3713bccde68e6260f79b1132eb00357be8c53fba04f3c827e97851cf SHA512 08b8ec7c1fbe5f1b8f95f95677012eeb9bd83951ee320470a0da852e0a446818e48ede7de045f6d7b98dff8be139fa69d780dbf03e65904c773f8ec1493f9915
 DIST lollypop-1.2.29.tar.xz 502720 BLAKE2B f3cb897595e057a5f5d4f420e1cbda7e992443b4c27b994f9eaf0f6cea21f6fa4b23cf6c2cf13c9fb019f92cd1bbeb018ac2fa8ce8ecf907d2d0b1ff944af72b SHA512 1e80013904c3ffa072b8a7707a6ff41f7877fcf740b8fbe58a0419e039dd0a9deedf5224cf6baa592830b452f9016ed881799a11fbb6e0fb30c7c0f519a44691
+DIST lollypop-1.2.32.tar.xz 504544 BLAKE2B ba93daa5d52d43401454c7c5e9fb05f2ef2d1d22de49da5d404120de0f6c41522a00c055fd190a5fe3a296174641773a322fab5548aceedee559987fac2ffd81 SHA512 08a4012ad252dcd6371479759547b082bcc12de0a76fc365519234e0d77dccc505cf264a352a3963cea722ce2820ea7a3521d23ab03d4695b95d88e678528c7b
diff --git a/media-sound/lollypop/lollypop-1.2.32.ebuild b/media-sound/lollypop/lollypop-1.2.32.ebuild
new file mode 100644 (file)
index 0000000..06db306
--- /dev/null
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="sqlite"
+inherit python-single-r1 gnome2-utils meson xdg-utils
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://adishatz.org/${PN}/${P}.tar.xz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="${PYTHON_DEPS}
+       dev-libs/appstream-glib[introspection]
+       dev-libs/glib:2
+       dev-libs/gobject-introspection[cairo(+)]
+       $(python_gen_cond_dep '
+               dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+               dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+       ')
+       gnome-base/gnome-common
+       x11-libs/gtk+:3
+"
+BDEPEND="${DEPEND}
+       $(python_gen_cond_dep '
+               dev-python/pkgconfig[${PYTHON_MULTI_USEDEP}]
+       ')
+       dev-util/desktop-file-utils
+       dev-util/itstool
+       dev-util/intltool
+"
+RDEPEND="${DEPEND}
+       app-crypt/libsecret[introspection]
+       dev-libs/totem-pl-parser
+       $(python_gen_cond_dep '
+               dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python
+               dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/pylast-1.0.0[${PYTHON_MULTI_USEDEP}]
+       ')
+       media-libs/gst-plugins-base:1.0[introspection]
+"
+
+RESTRICT="test"
+
+pkg_preinst() {
+       gnome2_schemas_savelist
+}
+
+src_install() {
+       meson_src_install
+       python_optimize
+}
+
+pkg_postinst() {
+       gnome2_gconf_install
+       gnome2_schemas_update
+       xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       gnome2_gconf_uninstall
+       gnome2_schemas_update
+       xdg_desktop_database_update
+}