dev-libs/libcec: Revert commit 7d0d59ad0d7581e5a9c9efc6020a2998b6183edc to get tree...
authorPatrice Clement <monsieurp@gentoo.org>
Sun, 3 Apr 2016 14:59:34 +0000 (14:59 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Sun, 3 Apr 2016 15:00:27 +0000 (15:00 +0000)
Package-Manager: portage-2.2.26

dev-libs/libcec/Manifest
dev-libs/libcec/libcec-3.1.0.ebuild [deleted file]

index 8865a24050613810b48296fe54f3918f6f03acbb..38ac81d27292e53a0488a1f365cc0bea67f38890 100644 (file)
@@ -2,4 +2,3 @@ DIST libcec-2.1.3.tar.gz 1087121 SHA256 2aa88451b528184b02077ee8c6cd10e2f89121a6
 DIST libcec-2.1.4.tar.gz 1093796 SHA256 79bef5232a5c9ab987ca3a2d4bfcaeb80480fd26f502dc1a996fe845d90fe147 SHA512 e2107b2003e003de8efea4b46a7776516652a2b27a0e0983a763324b3ac1ed2995cb0adb76e2f450bea72a1a0bdecfc5b3408fa702c74189204d694f5e9d2d8a WHIRLPOOL 4b8120755cf08dbc7ae8f2a5314f6c4e0c2ddc059b138ab594a26f7ac931cb34536a5bb2894a65902f1ba093007c1b08abeaf4306edef95059af8c85edad3e99
 DIST libcec-2.2.0.tar.gz 1099150 SHA256 fd4f47a18d6e0f4b9e6f5831280207ee2b2a5fc2741ae32ae09ad12a8aa52917 SHA512 7932a45e581e207aa651e9fe72450fda52b0441fb48e40e971a530f9d5d26b87e6446322393750d85bae223519dc2a73613352a3fe42939eff2c5f8863a09cd7 WHIRLPOOL ff8581c21e280fda6333aec840cbc08fd8d23ffa795fe173076d1863c0b8fdc86fb7838c2035940dac61362ec1c74054e6e450fff7ba5426ff57a2016c6eab83
 DIST libcec-3.0.1.tar.gz 1117284 SHA256 7e3670c8949a1964d6e5481f56dfff838857da10bdc60b506f6e9b7f117e253e SHA512 b579853d2d20d1007cb9128c8bb457da7c0c0138bba82fd45b05971be9c2232af6a064ab0a4f88bab10f6bda23baefffc43e717ad08b86bba3cf05c211ac5ee4 WHIRLPOOL 46583c7c8b45613a152fe37536992186a6929733dccde0399bed0cc86d07bb6e14da58ae42a12ee1ca192a2716b95b48bda9722749abfd40418b5f0f067f7a40
-DIST libcec-3.1.0.tar.gz 1097121 SHA256 09109d21a1b03f42c9e341d12600f2e4c41038d640269fa75408e2d36126f921 SHA512 e06f65d85ee268ec23380186d11e53f3e477bf25b955c9314cc13555eedeffee902dc8a0f3005248250c584760ab68c461b087b305dc4ef463da628ee1ab433b WHIRLPOOL 05e60255d00a897a53f042263ae73f61999875fe508a2fc6334cc00b62442d7e991a0f6a742acab440119ccdd34dfc842d97efe4fcb1a697181e76e3a0b414f8
diff --git a/dev-libs/libcec/libcec-3.1.0.ebuild b/dev-libs/libcec/libcec-3.1.0.ebuild
deleted file mode 100644 (file)
index 8888ca3..0000000
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-PYTHON_COMPAT=( python2_7 python3_4 )
-
-inherit cmake-utils eutils linux-info python-single-r1
-
-DESCRIPTION="Library for communicating with the Pulse-Eight USB HDMI-CEC Adaptor"
-HOMEPAGE="http://libcec.pulse-eight.com"
-SRC_URI="https://github.com/Pulse-Eight/${PN}/archive/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="cubox exynos python raspberry-pi +xrandr"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="virtual/udev
-       dev-libs/lockdev
-       dev-libs/libplatform
-       raspberry-pi? ( >=media-libs/raspberrypi-userland-0_pre20160305-r1 )
-       xrandr? ( x11-libs/libXrandr )"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig
-       python? (
-               dev-lang/swig
-               ${PYTHON_DEPS}
-       )"
-
-CONFIG_CHECK="~USB_ACM"
-
-S="${WORKDIR}/${PN}-${P}"
-
-pkg_setup() {
-       use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
-       # Do not hardcode the python libpath #577612
-       sed -i \
-               -e '/DESTINATION/s:lib/python${PYTHON_VERSION}/dist-packages:${PYTHON_SITEDIR}:' \
-               src/libcec/cmake/CheckPlatformSupport.cmake || die
-
-       cmake-utils_src_prepare
-       use python || comment_add_subdirectory "src/pyCecClient"
-}
-
-src_configure() {
-       local mycmakeargs=(
-               $(cmake-utils_useno python SKIP_PYTHON_WRAPPER)
-               $(cmake-utils_use_has exynos EXYNOS_API)
-               $(cmake-utils_use_has cubox TDA955X_API)
-               $(cmake-utils_use_has raspberry-pi RPI_API)
-       )
-       use python && mycmakeargs+=( -DPYTHON_SITEDIR="$(python_get_sitedir)" )
-
-       # raspberrypi-userland itself does not provide .pc file so using
-       # bcm_host.pc instead
-       if use raspberry-pi ; then
-               mycmakeargs+=( \
-                       -DRPI_INCLUDE_DIR=$(pkg-config --variable=includedir bcm_host) \
-                       -DRPI_LIB_DIR=$(pkg-config --variable=libdir bcm_host) )
-       fi
-
-       cmake-utils_src_configure
-}