app-misc/plod: EAPI 6 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Mon, 10 Apr 2017 23:40:56 +0000 (01:40 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 10 Apr 2017 23:41:35 +0000 (01:41 +0200)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-misc/plod/plod-1.9-r1.ebuild [new file with mode: 0644]

diff --git a/app-misc/plod/plod-1.9-r1.ebuild b/app-misc/plod/plod-1.9-r1.ebuild
new file mode 100644 (file)
index 0000000..645191a
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A tool designed to help administrators keep track of their daily activities"
+HOMEPAGE="http://www.deer-run.com/~hal/"
+SRC_URI="http://www.far2wise.net/plod/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-lang/perl"
+
+DOCS=( README )
+
+src_prepare() {
+       default
+       sed -i -e 's#/usr/local#/usr#' "${PN}" || die
+}
+
+src_compile() {
+       :;
+}
+
+src_install() {
+       dobin "${PN}"
+       doman "${PN}.1.gz"
+
+       insinto /etc
+       doins "${FILESDIR}/${PN}rc"
+       einstalldocs
+}