games-strategy/dopewars: fix building with ncurses[tinfo]
authorStefan Strogin <steils@gentoo.org>
Sat, 17 Aug 2019 04:40:25 +0000 (07:40 +0300)
committerStefan Strogin <steils@gentoo.org>
Sat, 17 Aug 2019 04:42:32 +0000 (07:42 +0300)
Closes: https://bugs.gentoo.org/690782
Package-Manager: Portage-2.3.71, Repoman-2.3.17
Signed-off-by: Stefan Strogin <steils@gentoo.org>
games-strategy/dopewars/dopewars-1.5.12-r3.ebuild

index 4d1c38437619d71f8afb19f59935a29ea42fe2b4..7da820832395edafeba67d4d0e127c22e1d89ccf 100644 (file)
@@ -1,8 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-inherit desktop
+
+inherit desktop toolchain-funcs
 
 DESCRIPTION="Re-Write of the game Drug Wars"
 HOMEPAGE="http://dopewars.sourceforge.net/"
@@ -36,6 +37,8 @@ src_prepare() {
                -e "/\/doc\// s:DPDATADIR:\"/usr/share\":" \
                -e 's:index.html:html/index.html:' \
                src/dopewars.c || die
+       sed -i -e "s/\-lncurses/$($(tc-getPKG_CONFIG) --libs ncurses)/g" \
+               configure || die
 }
 
 src_configure() {