x11-terms/tilda: Version bump (v1.5.1)
authorMikle Kolyada <zlogene@gentoo.org>
Fri, 8 May 2020 13:23:45 +0000 (16:23 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Fri, 8 May 2020 13:24:15 +0000 (16:24 +0300)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
x11-terms/tilda/Manifest
x11-terms/tilda/tilda-1.5.1.ebuild [new file with mode: 0644]

index 33e9e611c5e9676af22b445c3526ae10b30fe55a..a713fc4e37c0f5fd1ffd6d80a495262677307844 100644 (file)
@@ -1,2 +1,3 @@
 DIST tilda-1.4.1.tar.gz 471340 BLAKE2B a84d125bf81e384706347401ebbf7b11813bf5ed422e6b374e918ed564b9bfe168ebf3fef163b91a15350b49166b0040e90afdef716cc1762ecc410710f72c29 SHA512 d16878e762d94f94c219e8e711223a771a2ab816f02573f693cfbcfa0eee5aafff8a274898a65df168c0bf78258aa16e5a3be6b0c3dee418af61c68f43ed74c6
 DIST tilda-1.5.0.tar.gz 484754 BLAKE2B 8f04a5046b642e0cd67d375817d046920bbefd9b499458c2dab90f9801b0a4009b7b06cfe29af01095f1627581e4577ba5a7405948b29d21e233db288da48efd SHA512 2876b3ffbc5dd663b10c2f5fc7e6b838d6e3e18f30eb62afe07d9615b4567b04fba0b1efb2449204f4a5b78a90198092e397a24a41b978862d4fc6fab0b8de81
+DIST tilda-1.5.1.tar.gz 484980 BLAKE2B 530b3393e268b7eac47a89b96e5d139f71369f1bbdb5544beb0c6728fad9c52819a55e3e6f3836e00755d8bccbbf8b5bfd7f13347850684f0e74545e614fb9bb SHA512 58bba956adcc7adef11efc0c968bda2933543979759b1d477a1c040cf29cd5ef4382f13f220cde34162f23eedb3c987b81c139a3bae9d34106d18c9be08c9d90
diff --git a/x11-terms/tilda/tilda-1.5.1.ebuild b/x11-terms/tilda/tilda-1.5.1.ebuild
new file mode 100644 (file)
index 0000000..b7827af
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A drop down terminal, similar to the consoles found in first person shooters"
+HOMEPAGE="https://github.com/lanoxx/tilda"
+SRC_URI="https://github.com/lanoxx/tilda/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="x11-libs/vte:2.91
+       >=dev-libs/glib-2.8.4:2
+       dev-libs/confuse:=
+       gnome-base/libglade
+       x11-libs/gtk+:3
+       x11-libs/libX11"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       sys-devel/gettext"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+       default
+       append-cflags -std=c99
+       eautoreconf
+}