sys-cluster/glusterfs: version bump.
authorJaco Kroon <jaco@uls.co.za>
Tue, 5 May 2020 07:13:41 +0000 (09:13 +0200)
committerAlexys Jacob <ultrabug@gentoo.org>
Sat, 9 May 2020 20:22:08 +0000 (22:22 +0200)
Nothing in the Changelogs that looks like it should require changes to
the ebuild itself, so this ended up being a straight copy of 7.3

Closes: https://bugs.gentoo.org/721046
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Jaco Kroon <jaco@uls.co.za>
Closes: https://github.com/gentoo/gentoo/pull/15647
Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
sys-cluster/glusterfs/Manifest
sys-cluster/glusterfs/glusterfs-7.5.ebuild [new file with mode: 0644]

index 1b5162b006e97b7977f3ee9bbb58bc60d84fac8d..82df78bdd8ba21070d4d10be0cff03ed0bb4d408 100644 (file)
@@ -4,3 +4,4 @@ DIST glusterfs-6.7.tar.gz 7565257 BLAKE2B bb38383cad0cbf890b89dd75f7b260d21b381a
 DIST glusterfs-6.8.tar.gz 7572097 BLAKE2B 76b7c699a4fc864d8074b591b3583030d837a0beb63bb54e93458930a4af29bd9b1874dd33f0b7aecbf57d7dc454d448e67b71f38975281108a9fed76f9cf4aa SHA512 a28af19aa0ab2a356a2b7eff447d6b39ff821d7da59037e91a38d8cb43f51f7007b790f765fcbaccf9107554b59174e72d8b1ae9947e6342d2815bfae1adbad7
 DIST glusterfs-7.2.tar.gz 7630773 BLAKE2B abceafd06ca8f5de1c84708a1a3ec4453c5d536d8811b773fa6f5dd02d6e3d450c329bc4d0fa32d970ff57e82a1fe3aa48ec9c3a7d3d5ca5817a91e8930b1b6e SHA512 fd1059222c4d30fa5c4011083c3c53af44433180ae124c884a774628051d31d95386bef71d4d25ed2b0c5dd8d9a6936601e8e37d963b34d291cb88ea45e31ff2
 DIST glusterfs-7.3.tar.gz 7636144 BLAKE2B 8595e4eafc66b6b926d9aad220b569d7f5ae22b020ee3701db37f3db9dba6a33f805cebe322fb0423a1a8f18b85685411fa967beb34b03028d23b24725c5be00 SHA512 901f55d5084e90f4b5907fbbe7d5f7d1937198b500efc369651970053029b727c0bfc6180b6058a3211523b4e16a63bf821b1a9f81dfc1b87b2061d271ec9b3f
+DIST glusterfs-7.5.tar.gz 7649044 BLAKE2B 01088654051a33c3a009b42c6e7adf7cabc52927a83a3331eced428ed3e6bfb3f7198fcc53a2b1dce678ac58c2f2619d02cce72a9850a50f3a26b37d39baeeaa SHA512 dfd8f04fb398daa7d7f58ef978ab69c0a55a313ac2af3287f7e1e7044f708317227c8749af5fd8d56844dfb8ad47bbd3214c42b806e2e21191a6a8617ab0be38
diff --git a/sys-cluster/glusterfs/glusterfs-7.5.ebuild b/sys-cluster/glusterfs/glusterfs-7.5.ebuild
new file mode 100644 (file)
index 0000000..5812e98
--- /dev/null
@@ -0,0 +1,211 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit autotools elisp-common python-single-r1 systemd
+
+if [[ ${PV#9999} != ${PV} ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/gluster/glusterfs.git"
+else
+       SRC_URI="https://download.gluster.org/pub/gluster/${PN}/$(ver_cut 1)/${PV}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="GlusterFS is a powerful network/cluster filesystem"
+HOMEPAGE="https://www.gluster.org/"
+
+LICENSE="|| ( GPL-2 LGPL-3+ )"
+SLOT="0"
+IUSE="debug emacs +fuse +georeplication infiniband ipv6 libressl +libtirpc rsyslog static-libs +syslog test vim-syntax +xml"
+
+REQUIRED_USE="georeplication? ( ${PYTHON_REQUIRED_USE} )
+       ipv6? ( libtirpc )"
+
+# the tests must be run as root
+RESTRICT="test"
+
+# sys-apps/util-linux is required for libuuid
+RDEPEND="
+       acct-group/gluster
+       acct-user/gluster
+       dev-libs/libaio
+       dev-libs/userspace-rcu:=
+       net-libs/rpcsvc-proto
+       sys-apps/util-linux
+       sys-libs/readline:=
+       emacs? ( >=app-editors/emacs-23.1:* )
+       fuse? ( >=sys-fs/fuse-2.7.0:0 )
+       georeplication? ( ${PYTHON_DEPS} )
+       infiniband? ( sys-fabric/libibverbs:* sys-fabric/librdmacm:* )
+       xml? ( dev-libs/libxml2 )
+       !elibc_glibc? ( sys-libs/argp-standalone )
+       libtirpc? ( net-libs/libtirpc:= )
+       !libtirpc? ( elibc_glibc? ( sys-libs/glibc[rpc(-)] ) )
+       !libressl? ( dev-libs/openssl:=[-bindist] )
+       libressl? ( dev-libs/libressl:= )
+"
+DEPEND="
+       ${RDEPEND}
+       sys-devel/bison
+       sys-devel/flex
+       virtual/acl
+       test? ( >=dev-util/cmocka-1.0.1
+               app-benchmarks/dbench
+               dev-vcs/git
+               net-fs/nfs-utils
+               virtual/perl-Test-Harness
+               dev-libs/yajl
+               sys-fs/xfsprogs
+               sys-apps/attr )
+"
+BDEPEND="
+       virtual/pkgconfig
+"
+
+SITEFILE="50${PN}-mode-gentoo.el"
+
+DOCS=( AUTHORS ChangeLog NEWS README.md THANKS )
+
+# Maintainer notes:
+# * The build system will always configure & build argp-standalone but it'll never use it
+#   if the argp.h header is found in the system. Which should be the case with
+#   glibc or if argp-standalone is installed.
+
+pkg_setup() {
+       python_setup "python3*"
+       python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+
+       # https://bugs.gentoo.org/705536
+       # https://bugzilla.redhat.com/show_bug.cgi?id=1793990
+       eapply "${FILESDIR}/glusterfs-6.7-fix-seek.patch"
+
+       # build rpc-transport and xlators only once as shared libs
+       find rpc/rpc-transport xlators -name Makefile.am |
+               xargs sed -i 's|.*$(top_srcdir).*\.sym|\0 -shared|' || die
+
+       # fix execution permissions
+       chmod +x libglusterfs/src/gen-defaults.py || die
+
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --disable-fusermount \
+               $(use_enable debug) \
+               $(use_enable fuse fuse-client) \
+               $(use_enable georeplication) \
+               $(use_enable infiniband ibverbs) \
+               $(use_enable static-libs static) \
+               $(use_enable syslog) \
+               $(use_enable test cmocka) \
+               $(use_enable xml xml-output) \
+               $(use libtirpc || echo --without-libtirpc) \
+               $(use ipv6 && echo --with-ipv6-default) \
+               --with-tmpfilesdir="${EPREFIX}"/etc/tmpfiles.d \
+               --localstatedir="${EPREFIX}"/var
+}
+
+src_compile() {
+       default
+       use emacs && elisp-compile extras/glusterfs-mode.el
+}
+
+src_install() {
+       default
+
+       rm \
+               "${ED}"/etc/glusterfs/glusterfs-{georep-,}logrotate \
+               "${ED}"/etc/glusterfs/gluster-rsyslog-*.conf \
+               "${ED}"/usr/share/doc/${PF}/glusterfs{-mode.el,.vim} || die "removing false files failed"
+
+       insinto /etc/logrotate.d
+       newins "${FILESDIR}"/glusterfs.logrotate glusterfs
+
+       if use rsyslog ; then
+               insinto /etc/rsyslog.d
+               newins extras/gluster-rsyslog-7.2.conf 60-gluster.conf
+       fi
+
+       if use emacs ; then
+               elisp-install ${PN} extras/glusterfs-mode.el*
+               elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+       fi
+
+       if use vim-syntax ; then
+               insinto /usr/share/vim/vimfiles/ftdetect; doins "${FILESDIR}"/${PN}.vim
+               insinto /usr/share/vim/vimfiles/syntax; doins extras/${PN}.vim
+       fi
+
+       # insert some other tools which might be useful
+       insinto /usr/share/glusterfs/scripts
+       doins \
+               extras/backend-{cleanup,xattr-sanitize}.sh \
+               extras/clear_xattrs.sh \
+               extras/migrate-unify-to-distribute.sh
+
+       # correct permissions on installed scripts
+       # fperms 0755 /usr/share/glusterfs/scripts/*.sh
+       chmod 0755 "${ED}"/usr/share/glusterfs/scripts/*.sh || die
+
+       if use georeplication ; then
+               # move the gsync-sync-gfid tool to a binary path
+               # and set a symlink to be compliant with all other distros
+               mv "${ED}"/usr/{share/glusterfs/scripts/gsync-sync-gfid,libexec/glusterfs/} || die
+               dosym ../../../libexec/glusterfs/gsync-sync-gfid /usr/share/glusterfs/scripts/gsync-sync-gfid
+       fi
+
+       newinitd "${FILESDIR}/${PN}-r1.initd" glusterfsd
+       newinitd "${FILESDIR}/glusterd-r3.initd" glusterd
+       newconfd "${FILESDIR}/${PN}.confd" glusterfsd
+
+       keepdir /var/log/${PN}
+       keepdir /var/lib/glusterd/{events,glusterfind/.keys}
+
+       # QA
+       rm -r "${ED}/var/run/" || die
+       if ! use static-libs; then
+               find "${D}" -type f -name '*.la' -delete || die
+       fi
+}
+
+src_test() {
+       ./run-tests.sh || die
+}
+
+pkg_postinst() {
+       elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
+       elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
+       elog "  /etc/init.d/glusterd start"
+       echo
+       elog "For static configurations, the glusterfsd startup script can be multiplexed."
+       elog "The default startup script uses /etc/conf.d/glusterfsd to configure the"
+       elog "separate service.  To create additional instances of the glusterfsd service"
+       elog "simply create a symlink to the glusterfsd startup script."
+       echo
+       elog "Example:"
+       elog "    # ln -s glusterfsd /etc/init.d/glusterfsd2"
+       elog "    # ${EDITOR} /etc/glusterfs/glusterfsd2.vol"
+       elog "You can now treat glusterfsd2 like any other service"
+       echo
+       ewarn "You need to use a ntp client to keep the clocks synchronized across all"
+       ewarn "of your servers. Setup a NTP synchronizing service before attempting to"
+       ewarn "run GlusterFS."
+       echo
+       elog "If you are upgrading from a previous version of ${PN}, please read:"
+       elog "  http://docs.gluster.org/en/latest/Upgrade-Guide/upgrade_to_$(ver_cut '1-2')/"
+
+       use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+}