sci-calculators/units: Version bump.
authorJeroen Roovers <jer@gentoo.org>
Sat, 11 Mar 2017 05:30:52 +0000 (06:30 +0100)
committerJeroen Roovers <jer@gentoo.org>
Sat, 11 Mar 2017 05:30:52 +0000 (06:30 +0100)
Package-Manager: Portage-2.3.4, Repoman-2.3.2

sci-calculators/units/Manifest
sci-calculators/units/units-2.14.ebuild [new file with mode: 0644]

index fd62456fe8e68e192a230733310423a2f6310120..1f8d6e121337680bd1ebd7515adfbb294ea8290d 100644 (file)
@@ -1 +1,2 @@
 DIST units-2.13.tar.gz 1170233 SHA256 0ba5403111f8e5ea22be7d51ab74c8ccb576dc30ddfbf18a46cb51f9139790ab SHA512 39b380480ab6f48e56a7f122bb66f53ec49667f5ae3479a128536c58d29b1a1bfe281374f06911e8f713fe21459f57d13974c3629180b22968761cad15b10de2 WHIRLPOOL f1a4f85483e2cc9b4d2112a8ed36f51de7efc09b0ab6da926282d474615441f0196697d459cadb13aed1e5fa586261f7c45af2cc980be04b0fc810c57a7acb3e
+DIST units-2.14.tar.gz 1177024 SHA256 9d33893d82f3ddd831d5822992007c40bcd0826ae67d3cbc96539951fb0a82e8 SHA512 3cd09a76fb1cccbafaa3e023c791740738c8347425b2645cad1fa768dee3ebde917602cf65988ee8922fed512ec0bc2367f68545450789fc6bf1a79f066a6986 WHIRLPOOL ae4c0297387e9d3e42ae556a5f528f9c6f1b6a75f5f90580c5b9729ccdea011962d0e891c13ed583a97167bb62d5d074ab3b695ffdd23304f72a62098ce87821
diff --git a/sci-calculators/units/units-2.14.ebuild b/sci-calculators/units/units-2.14.ebuild
new file mode 100644 (file)
index 0000000..907add8
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_REQ_USE="xml"
+inherit eutils python-r1
+
+DESCRIPTION="Unit conversion program"
+HOMEPAGE="https://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+units_cur"
+
+DEPEND="
+       sys-libs/readline:=
+       units_cur? (
+               dev-lang/python-exec:2
+       )
+"
+RDEPEND="
+       ${DEPEND}
+       units_cur? (
+               dev-python/unidecode[${PYTHON_USEDEP}]
+               ${PYTHON_DEPS}
+       )
+"
+
+units_cur_prepare() {
+       local UNITS_PYTHON_MAJOR
+       UNITS_PYTHON_MAJOR=$(
+               UNITS_PYTHON_MAJOR=${EPYTHON/.*}
+               shopt -s extglob
+               echo ${UNITS_PYTHON_MAJOR/*([[:alpha:]])}
+       )
+       sed -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" units_cur${UNITS_PYTHON_MAJOR} > units_cur-${EPYTHON}
+}
+
+src_prepare() {
+       default
+
+       use units_cur && python_foreach_impl units_cur_prepare
+}
+
+src_compile() {
+       emake HAVE_PYTHON=no
+}
+
+units_cur_install() {
+       python_newexe units_cur-${EPYTHON} units_cur
+}
+
+src_install() {
+       emake DESTDIR="${D}" HAVE_PYTHON=no install
+
+       dodoc ChangeLog NEWS README
+
+       use units_cur && python_foreach_impl units_cur_install
+}