app-backup/untangle-https-backup: new EAPI=7 revision for python-3.{7,8}.
authorMichael Orlitzky <mjo@gentoo.org>
Sun, 19 Apr 2020 23:27:33 +0000 (19:27 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Sun, 19 Apr 2020 23:27:33 +0000 (19:27 -0400)
Closes: https://bugs.gentoo.org/718198
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
app-backup/untangle-https-backup/untangle-https-backup-0.0.10-r1.ebuild [new file with mode: 0644]

diff --git a/app-backup/untangle-https-backup/untangle-https-backup-0.0.10-r1.ebuild b/app-backup/untangle-https-backup/untangle-https-backup-0.0.10-r1.ebuild
new file mode 100644 (file)
index 0000000..16ff114
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+PYTHON_REQ_USE="ssl(+)"
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+DESCRIPTION="Back up Untangle configurations via the web admin UI"
+HOMEPAGE="http://michael.orlitzky.com/code/untangle-https-backup.xhtml"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_install() {
+       distutils-r1_src_install
+       doman "doc/man8/${PN}.8"
+       dodoc "doc/${PN}.example.ini"
+}