net-mail/mlmmj: tweak for gcc-10, bug #
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 30 Jan 2020 19:49:12 +0000 (19:49 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 30 Jan 2020 19:49:34 +0000 (19:49 +0000)
Reported-by: Toralf Förster
Closes: https://bugs.gentoo.org/707476
Package-Manager: Portage-2.3.86, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
net-mail/mlmmj/files/mlmmj-1.3.0-gcc-10.patch [new file with mode: 0644]
net-mail/mlmmj/mlmmj-1.3.0.ebuild

diff --git a/net-mail/mlmmj/files/mlmmj-1.3.0-gcc-10.patch b/net-mail/mlmmj/files/mlmmj-1.3.0-gcc-10.patch
new file mode 100644 (file)
index 0000000..8321724
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/include/mlmmj.h
++++ b/include/mlmmj.h
+@@ -81,7 +81,7 @@ enum subtype {
+       SUB_NONE /* For when an address is not subscribed at all */
+ };
+-char *subtype_strs[7]; /* count matches enum above; defined in subscriberfuncs.c */
++extern char *subtype_strs[7]; /* count matches enum above; defined in subscriberfuncs.c */
+ enum subreason {
+       SUB_REQUEST,
+@@ -92,7 +92,7 @@ enum subreason {
+       SUB_SWITCH
+ };
+-char * subreason_strs[6]; /* count matches enum above; defined in subscriberfuncs.c */
++extern char * subreason_strs[6]; /* count matches enum above; defined in subscriberfuncs.c */
+ void print_version(const char *prg);
index 66a6bc8a1e101dd2b689e95ef6ed1eeccb656fa0..c955caee300738f94cfbf91848b486d6a0e02f11 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -18,6 +18,7 @@ S="${WORKDIR}/${MY_P}"
 DOCS="AUTHORS ChangeLog FAQ README* TODO TUNABLES UPGRADE"
 PATCHES=(
        "${FILESDIR}"/mlmmj-1.2.19.0-listcontrol-customheaders.patch
+       "${FILESDIR}"/mlmmj-1.3.0-gcc-10.patch
 )
 
 src_configure() {