net-dialup/globespan-adsl: Remove last-rited pkg
authorMichał Górny <mgorny@gentoo.org>
Tue, 5 Nov 2019 22:29:07 +0000 (23:29 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 5 Nov 2019 22:29:07 +0000 (23:29 +0100)
Bug: https://bugs.gentoo.org/696252
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-dialup/globespan-adsl/Manifest [deleted file]
net-dialup/globespan-adsl/files/globespan-adsl-0.11-pagesize.patch [deleted file]
net-dialup/globespan-adsl/files/globespan-adsl-0.11-synch.patch [deleted file]
net-dialup/globespan-adsl/files/globespan-adsl-0.12-pagesize.patch [deleted file]
net-dialup/globespan-adsl/globespan-adsl-0.11-r1.ebuild [deleted file]
net-dialup/globespan-adsl/globespan-adsl-0.12.ebuild [deleted file]
net-dialup/globespan-adsl/metadata.xml [deleted file]
profiles/package.mask

diff --git a/net-dialup/globespan-adsl/Manifest b/net-dialup/globespan-adsl/Manifest
deleted file mode 100644 (file)
index d223360..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST eciadsl-usermode-0.11.tar.gz 323391 BLAKE2B 06919723382933ef813a00367e29919facf8bf65dcc94a56e6c7fef715ce8f1565402cd0dbdd442f42f5301229acb06995d3b20543f398acb4114daac4bce479 SHA512 4ac8f537538a5e1d93158bfb51810e331a684b424ad44cd3fa880dcfb3c2a3167900c29bc0b8762a30b3b565b08c64aca7446ac5d66ec4ee00ad706ea71d2dd7
-DIST eciadsl-usermode-0.12.tar.gz 338548 BLAKE2B f206b197883d9b53f9d44cadfbd08113da1ff50fc33037a93751e6fd83e095ea3d1d04ae642230644c778294f6ce0b1a2137cc43d1cbdf531bd6ed259965cafa SHA512 6f16d0ec0fecb133ff0057607324415aa6a6580e72d9950379a2307b77900651c101be1e762aed18fc3343935c7bb35085a51672f839c52d22d9493a41c4354d
diff --git a/net-dialup/globespan-adsl/files/globespan-adsl-0.11-pagesize.patch b/net-dialup/globespan-adsl/files/globespan-adsl-0.11-pagesize.patch
deleted file mode 100644 (file)
index dcb2141..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
---- eciadsl-usermode-0.11/pusb-linux.c.orig    2007-11-24 23:05:42.000000000 +0100
-+++ eciadsl-usermode-0.11/pusb-linux.c 2007-11-24 23:12:15.000000000 +0100
-@@ -29,7 +29,6 @@
- #include <string.h>
- #include "pusb-linux.h"
--#include <asm/page.h>
- struct pusb_endpoint_t
- {
-@@ -392,13 +391,18 @@
- {
-       struct usbdevfs_bulktransfer bulk;
-       int ret, received = 0;
-+      static long pagesize = 0;
-+      
-+      if (pagesize == 0)
-+              pagesize = sysconf(_SC_PAGESIZE);
-+              
-       do
-     {
-               bulk.ep      = ep;
-               bulk.len     = size;
--              if (bulk.len > PAGE_SIZE)
--                      bulk.len = PAGE_SIZE;
-+              if (size > pagesize)
-+                      bulk.len = pagesize;
-               bulk.timeout = timeout;
-               bulk.data    = buf;
diff --git a/net-dialup/globespan-adsl/files/globespan-adsl-0.11-synch.patch b/net-dialup/globespan-adsl/files/globespan-adsl-0.11-synch.patch
deleted file mode 100644 (file)
index 344ec3d..0000000
+++ /dev/null
@@ -1,85 +0,0 @@
-diff --git a/eciadsl-synch.c b/eciadsl-synch.c
-index 27c1f34..31c51dc 100644
---- a/eciadsl-synch.c
-+++ b/eciadsl-synch.c
-@@ -322,7 +322,7 @@ void read_endpoint(pusb_endpoint_t ep_int, int epnum){
-                 device. So we revert to the old behaviour : NO TIMEOUTS ...
-               */
--              ret = pusb_endpoint_read(ep_int, lbuf, sizeof(lbuf), 0);
-+              ret = pusb_endpoint_read_int(ep_int, lbuf, sizeof(lbuf));
-               
-               if (ret < 0)
-               {
-diff --git a/pusb-linux.c b/pusb-linux.c
-index 79b7545..b5bf1dd 100644
---- a/pusb-linux.c
-+++ b/pusb-linux.c
-@@ -340,6 +340,54 @@ int pusb_endpoint_rw_no_timeout(int fd, int ep,
-       return(purb->actual_length);
- }
-+int pusb_endpoint_read_int_no_timeout(int fd, int ep,
-+                     unsigned char* buf, int size)
-+{
-+      struct usbdevfs_urb urb, *purb = &urb;
-+      int ret;
-+
-+      memset(purb, 0, sizeof(urb));
-+
-+      purb->type = USBDEVFS_URB_TYPE_INTERRUPT;
-+      purb->endpoint = ep;
-+      purb->flags  = 0;
-+      purb->buffer = buf;
-+      purb->buffer_length = size;
-+      purb->signr = 0;
-+
-+      do
-+      {
-+              ret = ioctl(fd, USBDEVFS_SUBMITURB, purb);
-+      }
-+      while (ret < 0 && errno == EINTR);
-+
-+      if (ret < 0)
-+              return(ret);
-+
-+      do
-+      {
-+              ret = ioctl(fd, USBDEVFS_REAPURB, &purb);
-+      }
-+      while (ret < 0 && errno == EINTR);
-+
-+      if (ret < 0)
-+              return(ret);
-+
-+      if (purb != &urb)
-+              printf("purb=%p, &urb=%p\n", (void*)purb, (void*)&urb);
-+
-+      if (purb->buffer != buf)
-+              printf("purb->buffer=%p, buf=%p\n", (void*)purb->buffer, (void*)buf);
-+
-+      return(purb->actual_length);
-+}
-+
-+int pusb_endpoint_read_int(pusb_endpoint_t ep, 
-+                      unsigned char* buf, int size)
-+{
-+      return(pusb_endpoint_read_int_no_timeout(ep->fd, ep->ep|USB_DIR_IN, buf, size));
-+}
-+
- int pusb_endpoint_rw(int fd, int ep, unsigned char* buf, int size, int timeout)
- {
-       struct usbdevfs_bulktransfer bulk;
-diff --git a/pusb.h b/pusb.h
-index 921543b..112e41f 100644
---- a/pusb.h
-+++ b/pusb.h
-@@ -30,6 +30,8 @@ int pusb_release_interface(pusb_device_t dev,int interface);
- pusb_endpoint_t pusb_endpoint_open(pusb_device_t dev, int epnum, int flags);
- int pusb_endpoint_read(pusb_endpoint_t ep, 
-                      unsigned char *buf, int size, int timeout);
-+int pusb_endpoint_read_int(pusb_endpoint_t ep, 
-+                     unsigned char *buf, int size);
- int pusb_endpoint_write(pusb_endpoint_t ep, 
-                       const unsigned char *buf, int size, int timeout);
diff --git a/net-dialup/globespan-adsl/files/globespan-adsl-0.12-pagesize.patch b/net-dialup/globespan-adsl/files/globespan-adsl-0.12-pagesize.patch
deleted file mode 100644 (file)
index efed693..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-diff -Nru eciadsl-usermode-0.12.orig/pusb-linux.c eciadsl-usermode-0.12/pusb-linux.c
---- eciadsl-usermode-0.12.orig/pusb-linux.c    2007-08-25 08:41:28.000000000 +0300
-+++ eciadsl-usermode-0.12/pusb-linux.c 2007-08-25 08:42:27.000000000 +0300
-@@ -29,7 +29,6 @@
- #include <string.h>
- #include "pusb-linux.h"
--#include <asm/page.h>
- #include "pusb.h"
-@@ -430,16 +429,20 @@
- {
-       static struct usbdevfs_bulktransfer bulk;
-       static int ret;
-+      static long pagesize = 0;
-       int received = 0;
-+      if (pagesize == 0)
-+              pagesize = sysconf(_SC_PAGESIZE);
-+
-       do
-       {
-               bulk.ep      = ep;
-               bulk.len = size;
--              if (size > PAGE_SIZE)
--                      bulk.len = PAGE_SIZE;
-+              if (size > pagesize)
-+                      bulk.len = pagesize;
-               bulk.timeout = timeout;
-               bulk.data    = buf;
diff --git a/net-dialup/globespan-adsl/globespan-adsl-0.11-r1.ebuild b/net-dialup/globespan-adsl/globespan-adsl-0.11-r1.ebuild
deleted file mode 100644 (file)
index 251a2fe..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils
-
-MY_PN="eciadsl-usermode-${PV}"
-
-DESCRIPTION="Driver for various ADSL modems. Also known as EciAdsl"
-SRC_URI="http://eciadsl.flashtux.org/download/${MY_PN}.tar.gz"
-HOMEPAGE="http://eciadsl.flashtux.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE="tk"
-
-DEPEND="net-dialup/ppp"
-RDEPEND="${DEPEND}
-       dev-lang/perl
-       tk? ( >=dev-lang/tk-8.3.4 )"
-
-S="${WORKDIR}/${MY_PN}"
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       epatch "${FILESDIR}"/${P}-synch.patch
-       epatch "${FILESDIR}"/${P}-pagesize.patch
-}
-
-src_install() {
-       make DESTDIR="${D}" install || die "make install failed"
-       dodoc README* TROUBLESHOOTING* ChangeLog || die "failed to install documentation"
-}
-
-pkg_postinst() {
-       elog
-       elog "Package succesfully installed you should now run "
-       elog "eciconf.sh (graphical, requires TCL/TK) or eciconftxt.sh"
-       elog
-       elog "Paquetage installé avec succés vous devriez maintenant"
-       elog "executer eciconf.sh (qui requiert TCL/TK) ou eciconftxt.sh"
-       elog
-       ewarn "Please note that if you're using a 2.6.x kernel you'll"
-       ewarn "probably need to apply a patch to fix a USB bug. See"
-       ewarn "http://eciadsl.flashtux.org/download/beta/"
-       ewarn
-}
diff --git a/net-dialup/globespan-adsl/globespan-adsl-0.12.ebuild b/net-dialup/globespan-adsl/globespan-adsl-0.12.ebuild
deleted file mode 100644 (file)
index 29a0ed1..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils
-
-MY_PN="eciadsl-usermode-${PV}"
-
-DESCRIPTION="Driver for various ADSL modems. Also known as EciAdsl"
-SRC_URI="http://eciadsl.flashtux.org/download/${MY_PN}.tar.gz"
-HOMEPAGE="http://eciadsl.flashtux.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-amd64 x86"
-IUSE="tk"
-
-DEPEND="net-dialup/ppp"
-RDEPEND="${DEPEND}
-       dev-lang/perl
-       tk? ( >=dev-lang/tk-8.3.4 )"
-
-S="${WORKDIR}/${MY_PN}"
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       epatch "${FILESDIR}"/${P}-pagesize.patch
-}
-
-src_install() {
-       make DESTDIR="${D}" install || die "make install failed"
-       if ! use tk ; then
-               rm "${D}"/usr/bin/eciadsl-config-tk
-       fi
-       dodoc README* TROUBLESHOOTING* ChangeLog || die "failed to install documentation"
-}
-
-pkg_postinst() {
-       elog
-       elog "Package succesfully installed you should now run "
-       elog "eciconf.sh (graphical, requires TCL/TK) or eciconftxt.sh"
-       elog
-       elog "Paquetage installé avec succés vous devriez maintenant"
-       elog "executer eciconf.sh (qui requiert TCL/TK) ou eciconftxt.sh"
-       elog
-}
diff --git a/net-dialup/globespan-adsl/metadata.xml b/net-dialup/globespan-adsl/metadata.xml
deleted file mode 100644 (file)
index a814de5..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-<longdescription>ADSL modem driver for Globespan/ECI chipsets.</longdescription>
-</pkgmetadata>
index f401361fbdc9f0adaffd53f3fca32cc60320a15d..7d7a471f7e145c1690afea46eb387076437a9779 100644 (file)
@@ -398,7 +398,6 @@ mail-filter/clamsmtp
 mail-filter/disspam
 media-gfx/cthumb
 media-gfx/fblogo
-net-dialup/globespan-adsl
 sys-auth/pam_require
 
 # Michał Górny <mgorny@gentoo.org> (2019-10-04)