dev-games/physfs: Simplify USE=doc handling
authorDavid Seifert <soap@gentoo.org>
Mon, 13 May 2019 07:33:24 +0000 (09:33 +0200)
committerDavid Seifert <soap@gentoo.org>
Mon, 13 May 2019 07:33:24 +0000 (09:33 +0200)
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: David Seifert <soap@gentoo.org>
dev-games/physfs/metadata.xml
dev-games/physfs/physfs-3.0.2.ebuild
dev-games/physfs/physfs-9999.ebuild

index 4c12a220b846a1e1ce725873f68b42cfb2427025..2a68749c367a825c200b8e93887b8fb6f8199f2f 100644 (file)
@@ -1,36 +1,36 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<maintainer type="project">
-<email>games@gentoo.org</email>
-<name>Gentoo Games Project</name>
-</maintainer>
-<longdescription>
-PhysicsFS is a library to provide abstract access to various archives. It is 
-intended for use in video games, and the design was somewhat inspired by Quake 3's 
-file subsystem. The programmer defines a "write directory" on the physical 
-filesystem. No file writing done through the PhysicsFS API can leave that write 
-directory, for security. For example, an embedded scripting language cannot write 
-outside of this path if it uses PhysFS for all of its I/O, which means that 
-untrusted scripts can run more safely. Symbolic links can be disabled as well, for 
-added safety. For file reading, the programmer lists directories and archives that 
-form a "search path". Once the search path is defined, it becomes a single, 
-transparent hierarchical filesystem. This makes for easy access to ZIP files in the 
-same way as you access a file directly on the disk, and it makes it easy to ship a 
-new archive that will override a previous archive on a per-file basis. Finally, 
-PhysicsFS gives you platform-abstracted means to determine if CD-ROMs are available, 
-the user's home directory, where in the real filesystem your program is running, 
-etc.
-</longdescription>
-<use>
-<flag name="7zip">Enable 7zip/lzma archive support</flag>
-<flag name="grp">Enable Build Engine GRP archive support</flag>
-<flag name="hog">Enable Descent I/II HOG archive support</flag>
-<flag name="iso">Enable ISO9660 file support</flag>
-<flag name="mvl">Enable Descent I/II MVL archive support</flag>
-<flag name="slb">Enable Independence War SLB archive support</flag>
-<flag name="vdf">Enable Gothic/Gothic II VDF archive support</flag>
-<flag name="wad">Enable Doom WAD archive support</flag>
-<flag name="qpak">Enable Quake I/II QPAK archive support</flag>
-</use>
+       <maintainer type="project">
+               <email>games@gentoo.org</email>
+               <name>Gentoo Games Project</name>
+       </maintainer>
+       <longdescription>
+               PhysicsFS is a library to provide abstract access to various archives. It is
+               intended for use in video games, and the design was somewhat inspired by Quake 3's
+               file subsystem. The programmer defines a "write directory" on the physical
+               filesystem. No file writing done through the PhysicsFS API can leave that write
+               directory, for security. For example, an embedded scripting language cannot write
+               outside of this path if it uses PhysFS for all of its I/O, which means that
+               untrusted scripts can run more safely. Symbolic links can be disabled as well, for
+               added safety. For file reading, the programmer lists directories and archives that
+               form a "search path". Once the search path is defined, it becomes a single,
+               transparent hierarchical filesystem. This makes for easy access to ZIP files in the
+               same way as you access a file directly on the disk, and it makes it easy to ship a
+               new archive that will override a previous archive on a per-file basis. Finally,
+               PhysicsFS gives you platform-abstracted means to determine if CD-ROMs are available,
+               the user's home directory, where in the real filesystem your program is running,
+               etc.
+       </longdescription>
+       <use>
+               <flag name="7zip">Enable 7zip/lzma archive support</flag>
+               <flag name="grp">Enable Build Engine GRP archive support</flag>
+               <flag name="hog">Enable Descent I/II HOG archive support</flag>
+               <flag name="iso">Enable ISO9660 file support</flag>
+               <flag name="mvl">Enable Descent I/II MVL archive support</flag>
+               <flag name="slb">Enable Independence War SLB archive support</flag>
+               <flag name="vdf">Enable Gothic/Gothic II VDF archive support</flag>
+               <flag name="wad">Enable Doom WAD archive support</flag>
+               <flag name="qpak">Enable Quake I/II QPAK archive support</flag>
+       </use>
 </pkgmetadata>
index 0880049c9f1cfca149554004f069eb817147af00..91229a1b6d98b814deb9f9f1a1f099ea425f0fcb 100644 (file)
@@ -45,10 +45,9 @@ multilib_src_configure() {
 
 multilib_src_compile() {
        cmake-utils_src_compile
-       multilib_is_native_abi && use doc && cmake-utils_src_compile docs
-}
 
-multilib_src_install() {
-       multilib_is_native_abi && use doc && local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
-       cmake-utils_src_install
+       if multilib_is_native_abi && use doc; then
+               cmake-utils_src_compile docs
+               HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
+       fi
 }
index 0880049c9f1cfca149554004f069eb817147af00..91229a1b6d98b814deb9f9f1a1f099ea425f0fcb 100644 (file)
@@ -45,10 +45,9 @@ multilib_src_configure() {
 
 multilib_src_compile() {
        cmake-utils_src_compile
-       multilib_is_native_abi && use doc && cmake-utils_src_compile docs
-}
 
-multilib_src_install() {
-       multilib_is_native_abi && use doc && local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
-       cmake-utils_src_install
+       if multilib_is_native_abi && use doc; then
+               cmake-utils_src_compile docs
+               HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
+       fi
 }