dev-embedded/srecord: bump 1.64 to EAPI 6
authorTim Harder <radhermit@gentoo.org>
Fri, 9 Dec 2016 08:49:26 +0000 (03:49 -0500)
committerTim Harder <radhermit@gentoo.org>
Fri, 9 Dec 2016 08:49:26 +0000 (03:49 -0500)
dev-embedded/srecord/srecord-1.64.ebuild

index 0e0c7769702a859f89fa2e4d7be7056f5a62e953..d93b64995eb26f71ae23eb19d79e60d168ad27bd 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=5
+EAPI=6
 
 inherit eutils autotools
 
@@ -21,16 +21,17 @@ DEPEND="${RDEPEND}
        sys-apps/groff
        test? ( app-arch/sharutils )"
 
+PATCHES=( "${FILESDIR}"/${PN}-1.57-libtool.patch )
+
 src_prepare() {
-       epatch "${FILESDIR}"/${PN}-1.57-libtool.patch
+       default
 
        cp etc/configure.ac "${S}"
        eautoreconf
 }
 
 src_configure() {
-       econf \
-               $(use_enable static-libs static)
+       econf $(use_enable static-libs static)
 }
 
 src_install() {