net-mail/postfix-logwatch: new revision with a new patch.
authorMichael Orlitzky <mjo@gentoo.org>
Wed, 15 Apr 2020 12:13:10 +0000 (08:13 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Wed, 15 Apr 2020 12:59:14 +0000 (08:59 -0400)
The -r4 revision includes a patch to ignore the "DATA without valid
RCPT" notices that postscreen emits. The patch hasn't been upstreamed
because we're basically upstream at this point.

Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
net-mail/postfix-logwatch/files/data-without-valid-rcpt.patch [new file with mode: 0644]
net-mail/postfix-logwatch/postfix-logwatch-1.40.03-r4.ebuild [new file with mode: 0644]

diff --git a/net-mail/postfix-logwatch/files/data-without-valid-rcpt.patch b/net-mail/postfix-logwatch/files/data-without-valid-rcpt.patch
new file mode 100644 (file)
index 0000000..4c743a2
--- /dev/null
@@ -0,0 +1,33 @@
+From 891b5ce1780e10cd94d230efacf6e8b5cb33a931 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Wed, 15 Apr 2020 08:04:02 -0400
+Subject: [PATCH 1/1] Ignore postscreen "BDAT/DATA without valid RCPT" lines.
+
+Postscreen now emits a notice when clients send BDAT or DATA
+prematurely (after postscreen rejects the recipient):
+
+  DATA without valid RCPT from [192.168.0.1]:48580
+
+These are merely informational, since the connection was rejected for
+some other reason, so this commit ignores them.
+---
+ postfix-logwatch | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/postfix-logwatch b/postfix-logwatch
+index 648ba7a..1b89ad6 100644
+--- a/postfix-logwatch
++++ b/postfix-logwatch
+@@ -4359,7 +4359,8 @@ sub postfix_postscreen {
+       $line =~ /discarding EHLO keywords: / or
+       $line =~ /: discard_mask / or
+       $line =~ /: sq=\d+ cq=\d+ event/ or
+-      $line =~ /: replacing command "/
++      $line =~ /: replacing command "/ or
++      $line =~ /^(DATA|BDAT) without valid RCPT/
+    );
+-- 
+2.24.1
+
diff --git a/net-mail/postfix-logwatch/postfix-logwatch-1.40.03-r4.ebuild b/net-mail/postfix-logwatch/postfix-logwatch-1.40.03-r4.ebuild
new file mode 100644 (file)
index 0000000..e4fe1d2
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A log analyzer for postfix"
+HOMEPAGE="http://logreporters.sourceforge.net/"
+SRC_URI="mirror://sourceforge/logreporters/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/perl"
+
+PATCHES=(
+       "${FILESDIR}/unescaped-left-brace.patch"
+       "${FILESDIR}/redundant-argument-to-sprintf.patch"
+       "${FILESDIR}/multi-digit-enhanced-status.patch"
+       "${FILESDIR}/all-server-ports-busy-lines.patch"
+       "${FILESDIR}/data-without-valid-rcpt.patch"
+)
+
+src_prepare() {
+       default
+       # Replace the default config file location with ours.
+       local cfg_default='/usr/local/etc/${progname_prefix}-logwatch.conf'
+       local cfg_gentoo='/etc/${progname_prefix}-logwatch.conf';
+       sed -i "s~${cfg_default}~${cfg_gentoo}~" ${PN} \
+               || die 'failed to update the default config location'
+}
+
+src_compile() {
+       # The default make target just outputs instructions. We don't want
+       # the user to see these, so we avoid the default emake.
+       :
+}
+
+src_install() {
+       dodoc Bugs Changes README ${PN}.conf-topn
+       doman ${PN}.1
+       dobin ${PN}
+       insinto /etc
+       doins ${PN}.conf
+}