games-strategy/freeorion: Switch to PYTHON_MULTI_USEDEP API
authorMichał Górny <mgorny@gentoo.org>
Fri, 7 Feb 2020 14:12:03 +0000 (15:12 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 9 Feb 2020 16:22:04 +0000 (17:22 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
games-strategy/freeorion/freeorion-0.4.7.1-r4.ebuild
games-strategy/freeorion/freeorion-0.4.8_p20190501-r1.ebuild [moved from games-strategy/freeorion/freeorion-0.4.8_p20190501.ebuild with 92% similarity]
games-strategy/freeorion/freeorion-9999.ebuild

index e827e00ef9ecb930e2ca8a9b4792badb09fbabf3..3811c4a257492003b75e49e495d2f2b825bb37e3 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -26,7 +26,9 @@ IUSE=""
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RDEPEND="
-       >=dev-libs/boost-1.56:=[python,threads,${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-libs/boost-1.56:=[python,threads,${PYTHON_MULTI_USEDEP}]
+       ')
        media-libs/freealut
        media-libs/freetype
        media-libs/glew:=
similarity index 92%
rename from games-strategy/freeorion/freeorion-0.4.8_p20190501.ebuild
rename to games-strategy/freeorion/freeorion-0.4.8_p20190501-r1.ebuild
index 3aea6bd3b5d95aae80c38cfb39abd7f8bdd9ab8d..5bf1f6f4f99a86e3297a8bb694795fce8c20d5d5 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -34,7 +34,9 @@ BDEPEND="
        virtual/pkgconfig
 "
 RDEPEND="
-       >=dev-libs/boost-1.58:=[python,threads,${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-libs/boost-1.58:=[python,threads,${PYTHON_MULTI_USEDEP}]
+       ')
        !dedicated? (
                media-libs/freealut
                >=media-libs/freetype-2.5.5
index 3aea6bd3b5d95aae80c38cfb39abd7f8bdd9ab8d..5bf1f6f4f99a86e3297a8bb694795fce8c20d5d5 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -34,7 +34,9 @@ BDEPEND="
        virtual/pkgconfig
 "
 RDEPEND="
-       >=dev-libs/boost-1.58:=[python,threads,${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-libs/boost-1.58:=[python,threads,${PYTHON_MULTI_USEDEP}]
+       ')
        !dedicated? (
                media-libs/freealut
                >=media-libs/freetype-2.5.5