www-apache/passenger: add 6.0.2
authorHans de Graaff <graaff@gentoo.org>
Tue, 26 Feb 2019 06:59:37 +0000 (07:59 +0100)
committerHans de Graaff <graaff@gentoo.org>
Tue, 26 Feb 2019 06:59:37 +0000 (07:59 +0100)
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

www-apache/passenger/Manifest
www-apache/passenger/passenger-6.0.2.ebuild [new file with mode: 0644]

index a323f3e8c46d04816b6c003cd025261cead7cac3..1daf04c7d44f83484a4b9d362aa69fae34c87661 100644 (file)
@@ -1,2 +1,3 @@
 DIST passenger-5.3.7.tar.gz 7195477 BLAKE2B 43a2384574316f6c8472f326389e8c1feed769e78d66c20e63f6d2679b1ac1b20a9122612c98e3006520e6f24c5883addd93ef11e8f0385759ee0c9e9299b7ad SHA512 bbef4881e0e0c698b29b10ff8a7afbc001c31d14fb80ffa27ed6867a92ad23712319733e6162be1f7720ebda421630af2f258f8167fa73c7b5ea594bc8247158
 DIST passenger-6.0.1.tar.gz 7203144 BLAKE2B 1c59a4e7c6e82fc57f507653d8648cc8c21fae6ce8fb008b0839b60e6a076227f139300d7521eaff281ce2f935f20a730b3b34cb2cf3527a807f38e78219277d SHA512 d2fdd27367a2adc8e5486038c7bb9a504c13bc675ba9640123c1a091e6a891238c90c54a75938cd119d74f40c8d0b28257704c83ebefa024057c744ea845997d
+DIST passenger-6.0.2.tar.gz 7204982 BLAKE2B 056f85f88e49ca7dcfe37d1d1003beaa5325259a130b44aa60a319d36987c901b0a8a188998d38b68f3d396a71df0db8b8fc9562e58327b61a712dc39fb7ce1e SHA512 05a1c598588ad96864ef81ff8bc45535b3cb35c0f4840f16b93d39c0ece94378e806d967190a3d69b28b37d463624955bb45970459cf8febb258d8fd135e97f2
diff --git a/www-apache/passenger/passenger-6.0.2.ebuild b/www-apache/passenger/passenger-6.0.2.ebuild
new file mode 100644 (file)
index 0000000..e9d13ce
--- /dev/null
@@ -0,0 +1,127 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+inherit apache-module flag-o-matic multilib ruby-ng toolchain-funcs
+
+DESCRIPTION="Passenger makes deployment of Ruby on Rails applications a breeze"
+HOMEPAGE="https://www.phusionpassenger.com/"
+SRC_URI="https://s3.amazonaws.com/phusion-passenger/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="apache2 debug"
+
+ruby_add_bdepend "dev-ruby/rake"
+
+ruby_add_rdepend "
+       >=dev-ruby/rack-1.0.0:*
+       >=dev-ruby/rake-0.8.1"
+
+# libev is bundled but with adapations that do not seem to be accepted
+# upstream, so we must use the bundled version :-(
+CDEPEND="
+       >=dev-libs/libuv-1.8.0
+       net-misc/curl[ssl]
+       apache2? ( www-servers/apache[apache2_modules_unixd(+)] )"
+
+RDEPEND="${RDEPEND} ${CDEPEND}"
+DEPEND="${DEPEND} ${CDEPEND}"
+
+APACHE2_MOD_CONF="30_mod_${PN}-5.0.0 30_mod_${PN}"
+APACHE2_MOD_DEFINE="PASSENGER"
+
+want_apache2
+
+pkg_setup() {
+       use debug && append-flags -DPASSENGER_DEBUG
+       depend.apache_pkg_setup
+}
+
+all_ruby_prepare() {
+       eapply "${FILESDIR}"/${PN}-5.1.11-gentoo.patch
+       eapply "${FILESDIR}"/${PN}-5.1.1-isnan.patch
+
+       # Change these with sed instead of a patch so that we can easily use
+       # the toolchain-funcs methods.
+       sed -i -e "/^CC/ s/=.*$/= '$(tc-getCC)'/" \
+               -e "/^CXX\s/ s/=.*$/= '$(tc-getCXX)'/" \
+               -e 's/PlatformInfo.debugging_cflags//' build/basics.rb || die
+
+       # Avoid fixed debugging CFLAGs.
+       sed -e '/debugging_cflags/areturn ""' -i src/ruby_supportlib/phusion_passenger/platform_info/compiler.rb || die
+
+       # Use sed here so that we can dynamically set the documentation directory.
+       sed -i -e "s:/usr/share/doc/passenger:/usr/share/doc/${P}:" \
+               -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
+               src/ruby_supportlib/phusion_passenger.rb || die
+       sed -i -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" src/cxx_supportlib/ResourceLocator.h || die
+
+       # Don't install a tool that won't work in our setup.
+       sed -i -e '/passenger-install-apache2-module/d' src/ruby_supportlib/phusion_passenger/packaging.rb || die
+       rm -f bin/passenger-install-apache2-module || die "Unable to remove unneeded install script."
+
+       # Make sure we use the system-provided version where possible
+       rm -rf src/cxx_supportlib/vendor-copy/libuv || die "Unable to remove vendored code."
+
+       # Avoid building documentation to avoid a dependency on mizuho.
+       #sed -i -e 's/, :doc//' build/packaging.rb || die
+       touch doc/*.html || die
+
+       # Fix hard-coded use of AR
+       sed -i -e "s/ar cru/"$(tc-getAR)" cru/" build/support/cplusplus.rb || die
+
+       # Make sure apache support is not attempted with -apache2
+       if ! use apache2 ; then
+               sed -i -e '/fakeroot/ s/:apache2, //' build/packaging.rb || die
+       fi
+}
+
+all_ruby_compile() {
+       if use apache2 ; then
+               V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
+                APXS2="${APXS}" \
+                HTTPD="${APACHE_BIN}" \
+                FS_LIBDIR='/usr/'$(get_libdir) \
+                USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
+                ruby -S rake apache2 || die "rake failed"
+       fi
+}
+
+each_ruby_compile() {
+       append-flags -fno-strict-aliasing
+
+       V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
+       APXS2="${APXS}" \
+       HTTPD="${APACHE_BIN}" \
+       FS_LIBDIR='/usr/'$(get_libdir) \
+       USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
+       ${RUBY} -S rake native_support || die "rake failed"
+}
+
+all_ruby_install() {
+       if use apache2 ; then
+               APACHE2_MOD_FILE="${S}/buildout/apache2/mod_${PN}.so"
+               apache-module_src_install
+
+               # Patch in the correct libdir
+               sed -i -e 's:/usr/lib/:/usr/'$(get_libdir)'/:' "${D}${APACHE_MODULES_CONFDIR}/30_mod_${PN}.conf" || die
+       fi
+
+       dodoc CHANGELOG README.md
+}
+
+each_ruby_install() {
+       DISTDIR="${D}" \
+       RUBYLIBDIR="$(ruby_rbconfig_value vendordir)" \
+       RUBYARCHDIR="$(ruby_rbconfig_value archdir)" \
+       APXS2="${APXS}" \
+       HTTPD="${APACHE_BIN}" \
+       FS_LIBDIR='/usr/'$(get_libdir) \
+       EXTRA_LDFLAGS="${LDFLAGS}" \
+       USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
+       ${RUBY} -S rake fakeroot || die "rake failed"
+}