app-laptop/hdaps-gl: new EAPI=7 revision.
authorMichael Orlitzky <mjo@gentoo.org>
Sun, 10 Nov 2019 13:21:04 +0000 (08:21 -0500)
committerMichael Orlitzky <mjo@gentoo.org>
Sun, 10 Nov 2019 13:24:26 +0000 (08:24 -0500)
The ancient v0.0.5 is still the latest version, but surprisingly
it still works well. The new revision just cleans things up a bit.

Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
app-laptop/hdaps-gl/hdaps-gl-0.0.5-r1.ebuild [new file with mode: 0644]

diff --git a/app-laptop/hdaps-gl/hdaps-gl-0.0.5-r1.ebuild b/app-laptop/hdaps-gl/hdaps-gl-0.0.5-r1.ebuild
new file mode 100644 (file)
index 0000000..6e14527
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="OpenGL visualization for HDAPS data"
+HOMEPAGE="http://hdaps.sourceforge.net"
+SRC_URI="mirror://sourceforge/hdaps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND=""
+DEPEND="virtual/opengl
+       media-libs/freeglut"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-as-needed.diff" )
+
+src_compile() {
+       emake CC="$(tc-getCC)" \
+               CFLAGS="${CFLAGS} ${LDFLAGS}" \
+               || die "emake failed"
+}
+
+src_install() {
+       dobin "${PN}"
+}