games-engines/scummvm: Added "net" USE flag for optional cloud support
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 5 Nov 2019 09:58:26 +0000 (10:58 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 5 Nov 2019 09:58:26 +0000 (10:58 +0100)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
games-engines/scummvm/metadata.xml
games-engines/scummvm/scummvm-2.1.0.ebuild

index e71c4a5e17bb4a27da2cd47b87550f0de004888c..5ccc7bb685e0efd064945725325e2bbdb8351aa0 100644 (file)
@@ -8,6 +8,7 @@
   <use>
     <flag name="fluidsynth">compile with support for fluidsynth</flag>
     <flag name="mpeg2">enable mpeg2 codec for cutscenes</flag>
+    <flag name="net">enable cloud support via <pkg>media-libs/sdl2-net</pkg></flag>
     <flag name="speech">enable text-to-speech support through <pkg>app-accessibility/speech-dispatcher</pkg></flag>
     <flag name="unsupported">enable unsupported and/or broken game engines (you're on your own)</flag>
   </use>
index 4df7865efa7412d8da0339ec4fbaf0f592a283e4..fa2a0700cccba0a017f38b6bb85f55f688989a44 100644 (file)
@@ -11,12 +11,11 @@ SRC_URI="https://scummvm.org/frs/scummvm/${PV}/${P}.tar.xz"
 LICENSE="GPL-2+ LGPL-2.1 BSD GPL-3-with-font-exception"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="a52 aac alsa debug flac fluidsynth jpeg lua mpeg2 mp3 opengl png speech theora truetype unsupported vorbis zlib"
+IUSE="a52 aac alsa debug flac fluidsynth jpeg lua mpeg2 mp3 net opengl png speech theora truetype unsupported vorbis zlib"
 RESTRICT="test"  # it only looks like there's a test there #77507
 
 RDEPEND="
        >=media-libs/libsdl2-2.0.0[sound,joystick,video]
-       media-libs/sdl2-net
        a52? ( media-libs/a52dec )
        aac? ( media-libs/faad2 )
        alsa? ( media-libs/alsa-lib )
@@ -25,6 +24,7 @@ RDEPEND="
        jpeg? ( virtual/jpeg:0 )
        mp3? ( media-libs/libmad )
        mpeg2? ( media-libs/libmpeg2 )
+       net? ( media-libs/sdl2-net )
        opengl? ( virtual/opengl )
        png? ( media-libs/libpng:0 )
        speech? ( app-accessibility/speech-dispatcher )
@@ -84,6 +84,7 @@ src_configure() {
                $(use_enable lua)
                $(use_enable mp3 mad)
                $(use_enable mpeg2)
+               $(use_enable net sdlnet)
                $(use_enable png)
                $(use_enable speech tts)
                $(use_enable theora theoradec)