dev-libs/libunistring: clean up code to use more EAPI=5 logic
authorMike Frysinger <vapier@gentoo.org>
Wed, 10 Aug 2016 04:32:36 +0000 (12:32 +0800)
committerMike Frysinger <vapier@gentoo.org>
Wed, 10 Aug 2016 04:43:17 +0000 (12:43 +0800)
dev-libs/libunistring/libunistring-0.9.6.ebuild

index a276a20861221417a6564781256bda204a704716..08f726abdb86be357b4032c18cc0c5f219a30199 100644 (file)
@@ -1,6 +1,5 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
 EAPI="5"
 
@@ -24,13 +23,11 @@ src_configure() {
 }
 
 src_install() {
-       dodoc AUTHORS README ChangeLog || die "dodoc failed"
+       default
        if use doc; then
-               dohtml doc/*.html || die "dohtml failed"
-               doinfo doc/*.info || die "doinfo failed"
+               dohtml doc/*.html
+               doinfo doc/*.info
        fi
 
-       emake DESTDIR="${D}" install || die "Install failed"
-
        prune_libtool_files
 }