app-accessibility/orca: bump to 3.32.0
authorMart Raudsepp <leio@gentoo.org>
Sun, 20 Oct 2019 18:49:04 +0000 (21:49 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 20 Oct 2019 19:49:11 +0000 (22:49 +0300)
Package-Manager: Portage-2.3.69, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
app-accessibility/orca/Manifest
app-accessibility/orca/orca-3.32.0.ebuild [new file with mode: 0644]

index b8c045b8454fa826dc091bd38569f3cd9a9dc209..2e8affb379f12b03e7f83409f84357da640e4480 100644 (file)
@@ -1 +1,2 @@
 DIST orca-3.30.2.tar.xz 2493112 BLAKE2B 06ac902f67c66d5098be1829aa7cb7a160663a3a713d407a5245a95215c309f3b374937e4b70acbf9750f6e0e270ed8ab5516ca3cb6b0a19f347ee72a01a325b SHA512 146a132ce06f7f36d6d9397c507ea767be5df6c47a5c7485c35c325868ebc0b3ff7b3653572be82f6d5ed937033cd6d68a08700056a63e5691aed4c9171b3485
+DIST orca-3.32.0.tar.xz 2512032 BLAKE2B eae6c726e5e7361b7d60f0907f8c62c476895d681cf424940586e6308bcde147094a9557243aae6ecffef142bd556cb3cb30839955403e0958f123672400bf0a SHA512 015aa26ddaffa53d646e5d708ffed9e771beebbe925c27b963cbd3c3a2b36f730c0668cac6b89a371cd81cf8a570eb591711ba923fa4d013e00e31667749cf20
diff --git a/app-accessibility/orca/orca-3.32.0.ebuild b/app-accessibility/orca/orca-3.32.0.ebuild
new file mode 100644 (file)
index 0000000..62a38fb
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_REQ_USE="threads"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+       >=app-accessibility/at-spi2-atk-2.32:2
+       >=app-accessibility/at-spi2-core-2.32:2[introspection]
+       >=dev-libs/atk-2.32
+       >=dev-libs/glib-2.28:2
+       dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+       >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+       media-libs/gstreamer:1.0[introspection]
+       >=x11-libs/gtk+-3.6.2:3[introspection]
+       braille? (
+               >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+               dev-libs/liblouis[python,${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+       >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+       dev-libs/atk[introspection]
+       >=dev-python/pyatspi-2.32[${PYTHON_USEDEP}]
+       dev-python/setproctitle[${PYTHON_USEDEP}]
+       x11-libs/libwnck:3[introspection]
+       x11-libs/pango[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+       >=dev-util/intltool-0.50
+       dev-util/itstool
+       virtual/pkgconfig
+"
+#      app-text/yelp-tools
+
+src_configure() {
+       gnome2_src_configure \
+               $(use_with braille liblouis)
+}