app-emacs/d-mode: Fix compilation with Emacs 27.
authorUlrich Müller <ulm@gentoo.org>
Sun, 10 May 2020 09:49:49 +0000 (11:49 +0200)
committerUlrich Müller <ulm@gentoo.org>
Sun, 10 May 2020 10:23:59 +0000 (12:23 +0200)
Closes: https://bugs.gentoo.org/722012
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-emacs/d-mode/d-mode-2.0.10.ebuild
app-emacs/d-mode/files/d-mode-2.0.10-rx-form.patch [new file with mode: 0644]

index c410ee103834df500786cbf8fd90e04c6e084681..4a23ae67754751fd5e1e0e25fc41467a4a44d60b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -16,4 +16,5 @@ KEYWORDS="~amd64 ~x86"
 RESTRICT="test"
 
 S="${WORKDIR}/Emacs-D-Mode-${PV}"
+PATCHES=("${FILESDIR}"/${P}-rx-form.patch)
 SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/d-mode/files/d-mode-2.0.10-rx-form.patch b/app-emacs/d-mode/files/d-mode-2.0.10-rx-form.patch
new file mode 100644 (file)
index 0000000..78ed206
--- /dev/null
@@ -0,0 +1,25 @@
+https://bugs.gentoo.org/722012
+
+From cfd1d0869d51b7548b3fb738b2f2593c76533d44 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Per=20Nordl=C3=B6w?= <nordlow@users.noreply.github.com>
+Date: Wed, 9 Oct 2019 11:03:00 +0200
+Subject: [PATCH] Use rx-to-string instead of rx-form to support Emacs master
+ (#97)
+
+---
+ d-mode.el | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/d-mode.el b/d-mode.el
+index f8211cd..df72b8d 100644
+--- a/d-mode.el
++++ b/d-mode.el
+@@ -210,7 +210,7 @@ The expression is added to `compilation-error-regexp-alist' and
+   (add-to-list
+    'compilation-error-regexp-alist-alist
+    `(,symbol
+-     ,(rx-form
++     ,(rx-to-string
+       `(and
+       line-start
+       (group-n 1 (one-or-more any))           ; File name