dev-java/java-config: add python3_8 compat
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Thu, 7 May 2020 09:49:43 +0000 (02:49 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Thu, 7 May 2020 09:52:10 +0000 (02:52 -0700)
Bug: https://bugs.gentoo.org/719204
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-java/java-config/files/java-config-2.2.0-py38.patch [new file with mode: 0644]
dev-java/java-config/java-config-2.2.0-r4.ebuild

diff --git a/dev-java/java-config/files/java-config-2.2.0-py38.patch b/dev-java/java-config/files/java-config-2.2.0-py38.patch
new file mode 100644 (file)
index 0000000..cb59e1f
--- /dev/null
@@ -0,0 +1,52 @@
+From 5e7cc49184e657bd446998f4b08e9106e5215ce5 Mon Sep 17 00:00:00 2001
+From: Georgy Yakovlev <gyakovlev@gentoo.org>
+Date: Thu, 7 May 2020 02:45:57 -0700
+Subject: [PATCH] replace is with ==
+
+---
+ src/java-config-2 | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/java-config-2 b/src/java-config-2
+index 8ad2539..84ecd30 100755
+--- a/src/java-config-2
++++ b/src/java-config-2
+@@ -199,7 +199,7 @@ def set_user_vm(option, opt, value, parser):
+     if not vm:
+         fatalError("Could not find a vm matching: %s" % value)
+     else:
+-        if os.getuid() is 0:
++        if os.getuid() == 0:
+             fatalError("The user 'root' should always use the System VM")
+         else:
+             try:
+@@ -227,7 +227,7 @@ def user_classpath_target():
+ # Deprecated
+ def set_system_classpath(option, opt, value, parser):
+     deprecation_notice()
+-    if os.getuid() is 0:
++    if os.getuid() == 0:
+         pkgs = value.split(',')
+         manager.set_classpath(system_classpath_target(), pkgs)
+         
+@@ -252,7 +252,7 @@ def set_user_classpath(option, opt, value, parser):
+ # Deprecated
+ def append_system_classpath(option, opt, value, parser):
+     deprecation_notice()
+-    if os.getuid() is 0:
++    if os.getuid() == 0:
+         pkgs = value.split(',')
+         manager.append_classpath(system_classpath_target(), pkgs)
+@@ -277,7 +277,7 @@ def append_user_classpath(option, opt, value, parser):
+ # Deprecated
+ def clean_system_classpath(option, opt, value, parser):
+     deprecation_notice()
+-    if os.getuid() is 0:
++    if os.getuid() == 0:
+         manager.clean_classpath(system_classpath_target())
+         update_env()
+     else:
+-- 
+2.26.2
+
index 2913a8f7f682056068a43555c34f3121ac79650b..8f03a425121d36d614a3ce4ff6e27597e3203692 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=6
 
 # jython depends on java-config, so don't add it or things will break
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
 DISTUTILS_USE_SETUPTOOLS=no
 
 inherit distutils-r1
@@ -27,7 +27,10 @@ RDEPEND="
        sys-apps/baselayout-java
        sys-apps/portage[${PYTHON_USEDEP}]"
 
-PATCHES=( "${FILESDIR}"/${PN}-2.2.0-prefix.patch )
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.2.0-prefix.patch
+       "${FILESDIR}"/${PN}-2.2.0-py38.patch
+)
 
 python_install_all() {
        distutils-r1_python_install_all