app-eselect/eselect-php: tweak the live ebuild for upstream changes.
authorMichael Orlitzky <mjo@gentoo.org>
Thu, 23 Jan 2020 15:29:03 +0000 (10:29 -0500)
committerMichael Orlitzky <mjo@gentoo.org>
Thu, 23 Jan 2020 15:34:01 +0000 (10:34 -0500)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
app-eselect/eselect-php/eselect-php-9999.ebuild

index e6b5ef3d88043107d28b0d758a4acd75868ae27b..013fabe6fdd3a837704b406a569097cf62a0000e 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-inherit systemd git-r3 autotools
+inherit git-r3 autotools
 
 DESCRIPTION="PHP eselect module"
 HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
@@ -19,7 +19,7 @@ RDEPEND="app-admin/eselect
        apache2? ( www-servers/apache[apache2_modules_dir] )"
 
 src_prepare() {
-       eapply_user
+       default
        eautoreconf
 }
 
@@ -36,14 +36,3 @@ src_configure(){
                  $(use_enable apache2) \
                  $(use_enable fpm)
 }
-
-src_install() {
-       default
-
-       if use fpm ; then
-               systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
-               sed -e "s,@libdir@,$(get_libdir),g" "${FILESDIR}/php-fpm-launcher-r3" > "${T}"/php-fpm-launcher || die
-               exeinto /usr/libexec
-               doexe "${T}"/php-fpm-launcher
-       fi
-}