x11-terms/kitty: add imagemagick as optfeature
authorend222 <pabloorduna98@gmail.com>
Thu, 20 Feb 2020 13:07:28 +0000 (14:07 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 21 Feb 2020 05:31:08 +0000 (07:31 +0200)
Signed-off-by: Pablo Orduna <pabloorduna98@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/14715
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
x11-terms/kitty/kitty-0.16.0.ebuild

index c62b5d655696437279ef32deafac5c93f5ea7e25..eff516cfcbaaad5f427e3d7965529af84cd70a44 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python3_{6,7,8} )
 
-inherit python-single-r1 toolchain-funcs xdg
+inherit python-single-r1 toolchain-funcs xdg eutils
 
 if [[ ${PV} == "9999" ]] ; then
        EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
@@ -38,7 +38,6 @@ RDEPEND="
        x11-libs/libXrandr
        sys-apps/dbus
        sys-libs/zlib
-       virtual/imagemagick-tools
        wayland? (
                dev-libs/wayland
                >=dev-libs/wayland-protocols-1.17
@@ -94,6 +93,7 @@ src_install() {
 
 pkg_postinst() {
        xdg_icon_cache_update
+       optfeature "Displaying images in the terminal" virtual/imagemagick-tools
 }
 
 pkg_postrm() {