dev-libs/libdivsufsort: add openmp support
authorFrançois-Xavier Carton <fx.carton91@gmail.com>
Wed, 5 Dec 2018 19:32:38 +0000 (20:32 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 7 Dec 2018 16:26:55 +0000 (17:26 +0100)
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Signed-off-by: François-Xavier Carton <fx.carton91@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/10559
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-libs/libdivsufsort/libdivsufsort-2.0.1-r1.ebuild
dev-libs/libdivsufsort/libdivsufsort-9999.ebuild

index 3d6d79ec991086b6c660d62e71942492c4149d52..644a49823e3202e424e144727a48a589f1661846 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-inherit cmake-utils multilib
+inherit cmake-utils multilib toolchain-funcs
 
 DESCRIPTION="Suffix-sorting library (for BWT)"
 HOMEPAGE="https://github.com/y-256/libdivsufsort"
@@ -11,7 +11,15 @@ SRC_URI="https://github.com/y-256/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="openmp"
+
+pkg_pretend() {
+       [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+       [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
 
 src_prepare() {
        cmake-utils_src_prepare
@@ -22,6 +30,6 @@ src_prepare() {
 }
 
 src_configure() {
-       local mycmakeargs=("-DBUILD_DIVSUFSORT64=ON")
+       local mycmakeargs=("-DBUILD_DIVSUFSORT64=ON" "-DUSE_OPENMP=$(usex openmp)")
        cmake-utils_src_configure
 }
index 65e76c91651d1c4ef124d8ee97d7bbdf5ade9261..d6c33d70a4c56677b69f85040890bce940f389bc 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 EGIT_REPO_URI="https://github.com/y-256/${PN}"
-inherit cmake-utils multilib git-r3
+inherit cmake-utils multilib toolchain-funcs git-r3
 
 DESCRIPTION="Suffix-sorting library (for BWT)"
 HOMEPAGE="https://github.com/y-256/libdivsufsort"
@@ -12,7 +12,15 @@ SRC_URI=""
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS=""
-IUSE=""
+IUSE="openmp"
+
+pkg_pretend() {
+       [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+       [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
 
 src_prepare() {
        cmake-utils_src_prepare
@@ -23,6 +31,6 @@ src_prepare() {
 }
 
 src_configure() {
-       local mycmakeargs=("-DBUILD_DIVSUFSORT64=ON")
+       local mycmakeargs=("-DBUILD_DIVSUFSORT64=ON" "-DUSE_OPENMP=$(usex openmp)")
        cmake-utils_src_configure
 }