x11-terms/roxterm: Bump to 3.9.3
authorEwoud Kohl van Wijngaarden <ewoud@kohlvanwijngaarden.nl>
Tue, 21 Apr 2020 20:57:31 +0000 (22:57 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 28 Apr 2020 07:44:05 +0000 (10:44 +0300)
Closes: https://bugs.gentoo.org/581272
Closes: https://bugs.gentoo.org/718548
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Ewoud Kohl van Wijngaarden <ewoud@kohlvanwijngaarden.nl>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
x11-terms/roxterm/Manifest
x11-terms/roxterm/roxterm-3.9.3.ebuild [new file with mode: 0644]

index 2984ef800a2d340965044f9ce22167745012b673..4c180bf9a557235cb684735e5a542fcb4971c4a5 100644 (file)
@@ -1 +1,2 @@
 DIST roxterm-3.1.5.tar.xz 309892 BLAKE2B 11ede6d870a2aa96bfff4974ab33ac4814802f6b08e684f9367e3e268adc113be2b0c92eb337447f8d20a687c7be5f414854cf1f75831ef6c38f4d78d3897317 SHA512 f07989331b1cf915e94582bfceff8cb87f20613eb272ccc502fb49c7508a1330cfa3b137c59f300b8541595aed541867c1b0aad36809e7e9a326f7119fde2acd
+DIST roxterm-3.9.3.tar.gz 527056 BLAKE2B 442b9ee2605dd2b5e817ec792cab718eeed7aeacdd5a34582df780ee7fb970299985a49fda146c56dfa242d3a34098673fdcdbf7af96f1ab9e7c4340f08d78d9 SHA512 d3e29575a9985c8c967d9fa2b73d7dfd45cc13334b29c759219a90a3e0299c4d253a15e969be8c85c9aa12b1fddd390830fdb3ae99fea49d37a849e9881bd087
diff --git a/x11-terms/roxterm/roxterm-3.9.3.ebuild b/x11-terms/roxterm/roxterm-3.9.3.ebuild
new file mode 100644 (file)
index 0000000..af6a540
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="A terminal emulator designed to integrate with the ROX environment"
+HOMEPAGE="https://github.com/realh/roxterm"
+SRC_URI="https://github.com/realh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/dbus-glib
+       dev-libs/glib:2
+       dev-libs/libpcre2
+       sys-apps/dbus
+       x11-libs/gtk+:3
+       x11-libs/vte:2.91[vanilla]"
+# vanilla vte due to https://github.com/realh/roxterm/issues/222
+DEPEND="${RDEPEND}
+       dev-libs/libxslt"
+BDEPEND="virtual/pkgconfig"
+
+pkg_postinst() {
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}