net-mail/mailutils: bump to 3.9
authorEray Aslan <eras@gentoo.org>
Mon, 23 Mar 2020 11:51:07 +0000 (14:51 +0300)
committerEray Aslan <eras@gentoo.org>
Mon, 23 Mar 2020 11:51:07 +0000 (14:51 +0300)
Package-Manager: Portage-2.3.95, Repoman-2.3.21
Signed-off-by: Eray Aslan <eras@gentoo.org>
net-mail/mailutils/Manifest
net-mail/mailutils/files/mailutils-3.9-python-config.patch [new file with mode: 0644]
net-mail/mailutils/files/mailutils-3.9-underlinking.patch [new file with mode: 0644]
net-mail/mailutils/mailutils-3.9.ebuild [new file with mode: 0644]

index 87a0444dcad731ca615f5294777ab0b7dbeb84d0..06add80a10bcbeec62930223eee5fa5702b0657e 100644 (file)
@@ -1,3 +1,4 @@
 DIST mailutils-3.4.tar.xz 2619672 BLAKE2B 3a49c319a7171b2659477e6892ae222a342243e84ed2ee93e6d77353e1871d57d101a3a6ee3d2442709adbfb090e4931e134369661e8e8aa407061c1eccdf862 SHA512 548d97a4a036ef0ef5a429c82ffa43dd377b210b4c4d3844e7e5dded0f963060e3733b7766821c06ccf4dc1135002608658bcd6420e75b4ca1f4f17cfc8e2573
 DIST mailutils-3.7.tar.xz 2846864 BLAKE2B d407d370a4823972c060ea6c6a6e16eefe46598fee8302159f9d44fe150ace32b6915e7e3d4ddaca63ed5d5a5cffce48514f7f6297413a97692eb609a295622d SHA512 aa93ee1cde76392808f492dae6c69625ab124a2c31a296449ba217fc26f292871b4d04f8720bf20377177eab33c01cbfe195d6ac3674c35e1db53157a6916a4d
 DIST mailutils-3.8.tar.xz 2998596 BLAKE2B 4d09c7b5113129b3d2f3b113808d4460d025d4f0eec00dd1209a95f23abe97683b5d50cfe5229f1e5db48ddd6ca66c73fa6b0c1bfe03b324dbf40b6a26ff76f5 SHA512 4d081ae492beb0f9c1945541d63b52f155f11ca172abaedbe465955ac11097037f440e1aaed8d512cd3aab65f7792b755a7e4b9428a90ad7a833de87b1c4f1f9
+DIST mailutils-3.9.tar.xz 3075268 BLAKE2B 43ee5bf297951b3c894b467a46d3983dac3e115c02169da0ee2ccbc23f8b71d7439083093f4b0710f19c78f108df99dee3310f5f6adc5b7c1792a0a7be33aab6 SHA512 1eef9bebeeafbf974e54b87705444ee02b663a86e22442a9ec5db16ade38e6e9a3079ee8a8267393e97d6e9e477917617b2e1d57d3287ab19e4df73b66e5a8d4
diff --git a/net-mail/mailutils/files/mailutils-3.9-python-config.patch b/net-mail/mailutils/files/mailutils-3.9-python-config.patch
new file mode 100644 (file)
index 0000000..5a2ecdd
--- /dev/null
@@ -0,0 +1,27 @@
+From 5e3463bf6b5deb8ab5c6dffc6792a0a9a3bd7890 Mon Sep 17 00:00:00 2001
+From: Jordi Mallach <jordi@debian.org>
+Date: Sun, 22 Mar 2020 19:58:31 +0100
+Subject: Call $PYTHON_CONFIG instead of pyhon-config.
+
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6946a1aa6..4c089555a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1218,8 +1218,8 @@ if test "$status_python" = yes; then
+       esac
+       # See https://docs.python.org/dev/whatsnew/3.8.html#debug-build-uses-the-same-abi-as-release-build
+-      PYTHON_LIBS=`python-config --libs --embed 2>/dev/null` || \
+-         PYTHON_LIBS=`python-config --libs`
++      PYTHON_LIBS=`$PYTHON_CONFIG --libs --embed 2>/dev/null` || \
++         PYTHON_LIBS=`$PYTHON_CONFIG --libs`
+       PYTHON_INCLUDES=`$PYTHON_CONFIG --includes`
+     else
+       status_python=no     
+-- 
+cgit v1.2.1
+
diff --git a/net-mail/mailutils/files/mailutils-3.9-underlinking.patch b/net-mail/mailutils/files/mailutils-3.9-underlinking.patch
new file mode 100644 (file)
index 0000000..a7992af
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/configure.ac     2020-03-23 14:09:46.662589298 +0300
++++ b/configure.ac     2020-03-23 14:12:36.191030873 +0300
+@@ -958,7 +958,7 @@
+   AC_CHECK_LIB(ldap, ldap_bind,[
+    status_ldap=yes
+    AC_DEFINE(WITH_LDAP, 1, [Define to 1 if you want to use -lldap])
+-   MU_AUTHLIBS="${MU_AUTHLIBS}${MU_AUTHLIBS:+ }-lldap"],
++   MU_AUTHLIBS="${MU_AUTHLIBS}${MU_AUTHLIBS:+ }-lldap -llber"],
+    [status_ldap=no])
+ fi
diff --git a/net-mail/mailutils/mailutils-3.9.ebuild b/net-mail/mailutils/mailutils-3.9.ebuild
new file mode 100644 (file)
index 0000000..533d9f7
--- /dev/null
@@ -0,0 +1,141 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit autotools elisp-common eutils flag-o-matic python-single-r1 toolchain-funcs
+
+DESCRIPTION="A useful collection of mail servers, clients, and filters"
+HOMEPAGE="https://www.gnu.org/software/mailutils/mailutils.html"
+SRC_URI="mirror://gnu/mailutils/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="berkdb bidi +clients emacs gdbm sasl guile ipv6 kerberos kyotocabinet \
+       ldap mysql nls pam postgres python servers split-usr ssl static-libs +threads tcpd \
+       tokyocabinet"
+
+RDEPEND="!mail-client/nmh
+       !mail-filter/libsieve
+       !mail-client/mailx
+       !mail-client/nail
+       sys-libs/ncurses:=
+       sys-libs/readline:=
+       dev-libs/libltdl:0
+       virtual/mta
+       berkdb? ( sys-libs/db:= )
+       bidi? ( dev-libs/fribidi )
+       emacs? ( >=app-editors/emacs-23.1:* )
+       gdbm? ( sys-libs/gdbm )
+       guile? ( dev-scheme/guile:12/2.2-1 )
+       kerberos? ( virtual/krb5 )
+       kyotocabinet? ( dev-db/kyotocabinet )
+       ldap? ( net-nds/openldap )
+       mysql? ( dev-db/mysql-connector-c )
+       nls? ( sys-devel/gettext )
+       pam? ( sys-libs/pam )
+       postgres? ( dev-db/postgresql:= )
+       python? ( ${PYTHON_DEPS} )
+       sasl? ( virtual/gsasl )
+       servers? ( virtual/libiconv dev-libs/libunistring )
+       ssl? ( net-libs/gnutls:= )
+       tcpd? ( sys-apps/tcp-wrappers )
+       tokyocabinet? ( dev-db/tokyocabinet )"
+
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+       servers? ( tcpd ldap )"
+
+DOCS=( ABOUT-NLS AUTHORS COPYING COPYING.LESSER ChangeLog INSTALL NEWS README THANKS TODO )
+PATCHES=(
+       "${FILESDIR}"/${PN}-3.5-add-include.patch
+       "${FILESDIR}"/${PN}-3.9-underlinking.patch
+       "${FILESDIR}"/${PN}-3.8-fno-common.patch
+       "${FILESDIR}"/${PN}-3.9-python-config.patch
+)
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+       if use mysql; then
+               sed -i -e /^INCLUDES/"s:$:$(mysql_config --include):" \
+                       sql/Makefile.am || die
+       fi
+       eautoreconf
+}
+
+src_configure() {
+       append-flags -fno-strict-aliasing
+
+       # maildir is the Gentoo default
+       econf MU_DEFAULT_SCHEME=maildir \
+               CURSES_LIBS="$($(tc-getPKG_CONFIG) --libs ncurses)" \
+               $(use_with berkdb berkeley-db) \
+               $(use_with bidi fribidi) \
+               $(use_enable ipv6) \
+               $(use_with gdbm) \
+               $(use_with sasl gsasl) \
+               $(use_with guile) \
+               $(use_with kerberos gssapi) \
+               $(use_with ldap) \
+               $(use_with mysql) \
+               $(use_enable nls) \
+               $(use_enable pam) \
+               $(use_with postgres) \
+               $(use_enable python) \
+               $(use_with ssl gnutls) \
+               $(use_enable static-libs static) \
+               $(use_enable threads pthread) \
+               $(use_with tokyocabinet) \
+               $(use_with kyotocabinet) \
+               $(use_with tcpd tcp-wrappers) \
+               $(use_enable servers build-servers) \
+               $(use_with servers unistring ) \
+               $(use_enable clients build-clients) \
+               EMACS=$(usex emacs emacs no) \
+               --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
+               --with-mail-spool=/var/spool/mail \
+               --with-readline \
+               --enable-sendmail \
+               --disable-debug
+}
+
+src_install() {
+       default
+
+       insinto /etc
+       # bug 613112
+       newins "${FILESDIR}/mailutils.rc" mailutils.conf
+       keepdir /etc/mailutils.d/
+       insinto /etc/mailutils.d
+       doins "${FILESDIR}/mail"
+
+       if use python; then
+               python_optimize
+               if use static-libs; then
+                       rm -r "${D}$(python_get_sitedir)/mailutils"/*.{a,la} || die
+               fi
+       fi
+
+       if use servers; then
+               newinitd "${FILESDIR}"/imap4d.initd imap4d
+               newinitd "${FILESDIR}"/pop3d.initd pop3d
+               newinitd "${FILESDIR}"/comsatd.initd comsatd
+       fi
+
+       # compatibility link
+       if use clients && use split-usr; then
+               dosym ../usr/bin/mail /bin/mail
+       fi
+
+       if ! use static-libs; then
+               find "${D}" -name "*.la" -delete || die
+       fi
+}