sci-misc/boinc: update icon cache in 7.8.4 as well
authorMart Raudsepp <leio@gentoo.org>
Thu, 21 Dec 2017 10:44:08 +0000 (12:44 +0200)
committerMart Raudsepp <leio@gentoo.org>
Thu, 21 Dec 2017 10:46:54 +0000 (12:46 +0200)
This brings in the iconcache update fix from 7.8.1-r1 that was
pushed while 7.8.4 PR was still unmerged. But without the
redundant gnome2_icon_savelist call, as the conditional to
only call cache update isn't inside itself since a while now.

Bug: https://bugs.gentoo.org/636886
Package-Manager: Portage-2.3.19, Repoman-2.3.6

sci-misc/boinc/boinc-7.8.4.ebuild

index b29f7289978377e50a2d7a2e124fbbaf0f99eaed..b4628e19804eca7b484143afc26252a4b6afdfe6 100644 (file)
@@ -5,7 +5,7 @@ EAPI=6
 
 WX_GTK_VER=3.0-gtk3
 
-inherit autotools eutils linux-info systemd user versionator wxwidgets
+inherit autotools eutils gnome2-utils linux-info systemd user versionator wxwidgets
 
 MY_PV=$(get_version_component_range 1-2)
 
@@ -67,7 +67,7 @@ pkg_setup() {
                        ewarn "Can't check the linux kernel configuration."
                        ewarn "You might be missing vsyscall support."
                elif kernel_is -ge 4 4 \
-                   && linux_chkconfig_present LEGACY_VSYSCALL_NONE; then
+                       && linux_chkconfig_present LEGACY_VSYSCALL_NONE; then
                        ewarn "You do not have vsyscall emulation enabled."
                        ewarn "This will prevent some boinc projects from running."
                        ewarn "Please enable vsyscall emulation:"
@@ -145,6 +145,8 @@ pkg_preinst() {
 }
 
 pkg_postinst() {
+       gnome2_icon_cache_update
+
        elog
        elog "You are using the source compiled version of boinc."
        use X && elog "The graphical manager can be found at /usr/bin/boincmgr"
@@ -179,3 +181,7 @@ pkg_postinst() {
        fi
        elog
 }
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}