dev-ml/ocamlbuild: bump to 0.14.0
authorJason A. Donenfeld <zx2c4@gentoo.org>
Fri, 27 Dec 2019 18:09:35 +0000 (19:09 +0100)
committerJason A. Donenfeld <zx2c4@gentoo.org>
Fri, 27 Dec 2019 18:09:35 +0000 (19:09 +0100)
This appears to be unmaintained, and the old ebuild no longer builds
with new ocaml, but thankfully this newer ocamlbuild does. Let's bump it
and see what happens.

Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
dev-ml/ocamlbuild/Manifest
dev-ml/ocamlbuild/ocamlbuild-0.14.0.ebuild [new file with mode: 0644]

index bf2beb74a20b0ebb9ad5ebc737286396424d93f6..2582af8317bb1fa31db0368b541e6aa3844f3a13 100644 (file)
@@ -1,2 +1,3 @@
 DIST ocamlbuild-0.10.1.tar.gz 193263 BLAKE2B cee82997a6b691b3df9b92055b74f05af57d7663f5dbb84701e66dffefcfe6ec00c9721e1872d546f2aea9237068e37ba7d94463d0002a8356dd4d84bc1865c0 SHA512 6d74bdce7fe147bf1a5fd570b569925b36b5f443c7251d1c13a0525e3086417b393a768722bf7d4b23a7e3178b0b3c2511499725c5a755d69783b8d555663e3b
 DIST ocamlbuild-0.11.0.tar.gz 195297 BLAKE2B 2d653c402edf58035fa6efb65c99c956fe78efc4759f29c8ddab8263310a5d243d25d37d4c1a4f0699f151afb6d4c6df4c1550f95d6e915963b3d86923877225 SHA512 14bc44cc63b6c99e711658a1145247bad8263632fbb4550238cef15e226a76b83e51b83575a7a96f16b96ec321dedd0ef23f36166c354838aec1922f58179efd
+DIST ocamlbuild-0.14.0.tar.gz 198267 BLAKE2B 355d61ba68e61b9ee18a9fc0fbb9062405f44707b180ca7ad4bfec727ca3d3d2cc08f17be118ca3a4161c7789d975e7f431812e9139d4fde85a1a27ab68c8ac3 SHA512 ae60247396399dfd35644c8c1986ef7679e5a9964df82e3388bfc6dd4c5b88a13d6869a698d14a9ac70dc48e4ce1c003f543c85426d8c862ca31dea37a554b07
diff --git a/dev-ml/ocamlbuild/ocamlbuild-0.14.0.ebuild b/dev-ml/ocamlbuild/ocamlbuild-0.14.0.ebuild
new file mode 100644 (file)
index 0000000..4556ac4
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Generic build tool with built-in rules for building OCaml library and programs"
+HOMEPAGE="https://github.com/ocaml/ocamlbuild"
+SRC_URI="https://github.com/ocaml/ocamlbuild/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?]"
+RDEPEND="${DEPEND}
+       !<dev-ml/findlib-1.6.1-r1
+"
+DEPEND="${DEPEND}
+       test? ( dev-ml/findlib )"
+
+src_configure() {
+       emake -f configure.make Makefile.config \
+               PREFIX="${EPREFIX}/usr" \
+               BINDIR="${EPREFIX}/usr/bin" \
+               LIBDIR="$(ocamlc -where)" \
+               OCAML_NATIVE=$(usex ocamlopt true false) \
+               OCAML_NATIVE_TOOLS=$(usex ocamlopt true false) \
+               NATDYNLINK=$(usex ocamlopt true false)
+}
+
+src_install() {
+       emake CHECK_IF_PREINSTALLED=false DESTDIR="${D}" install
+       dodoc Changes
+}