games-strategy/satellite-reign: New package
authorJames Le Cuirot <chewi@gentoo.org>
Tue, 24 Sep 2019 22:28:26 +0000 (23:28 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Tue, 24 Sep 2019 22:28:26 +0000 (23:28 +0100)
Tested with the Humble Bundle release. It could be extended to work
with GOG too but I'd need to see the file layout.

Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-strategy/satellite-reign/Manifest [new file with mode: 0644]
games-strategy/satellite-reign/metadata.xml [new file with mode: 0644]
games-strategy/satellite-reign/satellite-reign-1.13.06.ebuild [new file with mode: 0644]

diff --git a/games-strategy/satellite-reign/Manifest b/games-strategy/satellite-reign/Manifest
new file mode 100644 (file)
index 0000000..30fc43c
--- /dev/null
@@ -0,0 +1 @@
+DIST SatelliteReignLinux0113_06.zip 674306806 BLAKE2B 4525fdb2568d631422a23ba9b3fcffaf3e2f62e146e96c3468c3305507589698ac94f60302d4fe7cde0e3359dd1ad1f88232f6c749be1d63450b121cd8c219d1 SHA512 66ec91728c664975cb2c45b287465fb38fd40e1dcaa7cfe19bbbdeb040cefab1ce349f160e46171a276f3bdd068a4a584379e9899dd7052c4fd1ecd74936c43e
diff --git a/games-strategy/satellite-reign/metadata.xml b/games-strategy/satellite-reign/metadata.xml
new file mode 100644 (file)
index 0000000..1dbebd8
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>games@gentoo.org</email>
+               <name>Gentoo Games Project</name>
+       </maintainer>
+       <use>
+               <flag name="gui">Install the GUI for configuring screen resolution and input</flag>
+       </use>
+</pkgmetadata>
diff --git a/games-strategy/satellite-reign/satellite-reign-1.13.06.ebuild b/games-strategy/satellite-reign/satellite-reign-1.13.06.ebuild
new file mode 100644 (file)
index 0000000..c6913d9
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils desktop xdg-utils
+
+MY_PN="SatelliteReignLinux"
+MY_PV="${PV/.}"
+MY_PV="0${MY_PV/./_}"
+
+DESCRIPTION="Real-time, class-based strategy game set in a cyberpunk city"
+HOMEPAGE="http://satellitereign.com/"
+SRC_URI="${MY_PN}${MY_PV}.zip"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+gui"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+       virtual/opengl
+       x11-libs/libX11
+       x11-libs/libXcursor
+       x11-libs/libXrandr
+       gui? (
+               dev-libs/glib:2
+               x11-libs/gdk-pixbuf:2
+               x11-libs/gtk+:2
+       )
+"
+
+S="${WORKDIR}"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR}/*"
+
+pkg_nofetch() {
+       einfo "Please buy and download ${SRC_URI} from:"
+       einfo "  https://www.humblebundle.com/store/${PN}"
+       einfo "and move it to your distfiles directory."
+}
+
+src_install() {
+       exeinto "${DIR}"
+       newexe ${MY_PN}.$(usex amd64 x86_64 x86) ${MY_PN}
+       make_wrapper ${PN} "${DIR}"/${MY_PN}
+
+       insinto "${DIR}"
+       doins -r ${MY_PN}_Data/
+       rm -r "${ED}/${DIR}"/${MY_PN}_Data/*/$(usex amd64 x86 x86_64) || die
+
+       if ! use gui; then
+               rm "${ED}/${DIR}"/${MY_PN}_Data/Plugins/*/ScreenSelector.so || die
+       fi
+
+       newicon -s 128 ${MY_PN}_Data/Resources/UnityPlayer.png ${PN}.png
+       make_desktop_entry ${PN} "Satellite Reign"
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }