net-im/zoom: Several fixes.
authorUlrich Müller <ulm@gentoo.org>
Sat, 28 Mar 2020 12:14:50 +0000 (13:14 +0100)
committerUlrich Müller <ulm@gentoo.org>
Sat, 28 Mar 2020 12:15:05 +0000 (13:15 +0100)
Fix problem that ALSA devices are not found if media-sound/apulse[sdk]
is installed.

Add missing dependency on media-libs/libjpeg-turbo and a symlink
(for dlopen?) to fix a camera problem.

Install a better icon. Generic camera icon taken from
https://github.com/google/material-design-icons/blob/master/av/svg/production/ic_videocam_24px.svg
(licensed under Apache-2.0) and locally modified.

Closes: https://bugs.gentoo.org/715106
Closes: https://bugs.gentoo.org/715088
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
net-im/zoom/files/zoom-videocam.svg [new file with mode: 0644]
net-im/zoom/zoom-3.5.374815.0324-r1.ebuild [moved from net-im/zoom/zoom-3.5.374815.0324.ebuild with 58% similarity]

diff --git a/net-im/zoom/files/zoom-videocam.svg b/net-im/zoom/files/zoom-videocam.svg
new file mode 100644 (file)
index 0000000..33e4ac7
--- /dev/null
@@ -0,0 +1,4 @@
+<svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24">
+  <rect width="24" height="24" rx="6" ry="6" fill="#2d8cff"/>
+  <path d="M17 10.5V7c0-.55-.45-1-1-1H4c-.55 0-1 .45-1 1v10c0 .55.45 1 1 1h12c.55 0 1-.45 1-1v-3.5l4 4v-11l-4 4z" fill="#ffffff"/>
+</svg>
similarity index 58%
rename from net-im/zoom/zoom-3.5.374815.0324.ebuild
rename to net-im/zoom/zoom-3.5.374815.0324-r1.ebuild
index c9475297484f3c2be52933d3b5a6dd64d66c22e7..4aa816a1c6acbe58e520b054ecf4f685fc0bf865 100644 (file)
@@ -11,9 +11,10 @@ SRC_URI="amd64? ( https://zoom.us/client/${PV}/${PN}_x86_64.tar.xz -> ${P}_x86_6
        x86? ( https://zoom.us/client/${PV}/${PN}_i686.tar.xz -> ${P}_i686.tar.xz )"
 S="${WORKDIR}/${PN}"
 
-LICENSE="all-rights-reserved"
+LICENSE="all-rights-reserved Apache-2.0" # Apache-2.0 for icon
 SLOT="0"
 KEYWORDS="-* ~amd64 ~x86"
+IUSE="pulseaudio"
 RESTRICT="mirror bindist strip"
 
 RDEPEND="dev-libs/glib:2
@@ -31,6 +32,7 @@ RDEPEND="dev-libs/glib:2
        dev-qt/qtwebengine:5
        dev-qt/qtwidgets:5
        media-libs/libglvnd
+       media-libs/libjpeg-turbo
        sys-apps/dbus
        sys-apps/util-linux
        x11-libs/libX11
@@ -39,10 +41,24 @@ RDEPEND="dev-libs/glib:2
        x11-libs/libXfixes
        x11-libs/libXtst
        x11-libs/xcb-util-image
-       x11-libs/xcb-util-keysyms"
+       x11-libs/xcb-util-keysyms
+       pulseaudio? ( media-sound/pulseaudio )"
+
+BDEPEND="!pulseaudio? ( dev-util/bbe )"
 
 QA_PREBUILT="opt/zoom/*"
 
+src_prepare() {
+       default
+       if ! use pulseaudio; then
+               # For some strange reason, zoom cannot use any ALSA sound devices if
+               # it finds libpulse. This causes breakage if media-sound/apulse[sdk]
+               # is installed. So, force zoom to ignore libpulse.
+               bbe -e 's/libpulse.so/IgNoRePuLsE/' zoom >zoom.tmp || die
+               mv zoom.tmp zoom || die
+       fi
+}
+
 src_install() {
        insinto /opt/zoom
        exeinto /opt/zoom
@@ -50,9 +66,15 @@ src_install() {
        doins *.pcm *.pem *.sh Embedded.properties version.txt
        use amd64 && doins icudtl.dat
        doexe zoom{,.sh,linux} zopen ZoomLauncher
+       dosym {"../../usr/$(get_libdir)",/opt/zoom}/libturbojpeg.so #715106
+
        make_wrapper zoom ./zoom /opt/zoom
-       make_desktop_entry "zoom %U" Zoom audio-headset "" \
-               "MimeType=x-scheme-handler/zoommtg;application/x-zoom;"
+       make_desktop_entry "zoom %U" Zoom zoom-videocam "" \
+                                          "MimeType=x-scheme-handler/zoommtg;application/x-zoom;"
+       # The tarball doesn't contain an icon, so take a generic camera icon
+       # from https://github.com/google/material-design-icons, modified to be
+       # white on a blue background
+       doicon "${FILESDIR}"/zoom-videocam.svg
 }
 
 pkg_postinst() {