net-mail/mboxgrep: Fix building with CFLAGS=-fno-common
authorJeroen Roovers <jer@gentoo.org>
Sun, 17 May 2020 12:05:59 +0000 (14:05 +0200)
committerJeroen Roovers <jer@gentoo.org>
Sun, 17 May 2020 12:10:20 +0000 (14:10 +0200)
Also:
- Add missing dependencies
- EAPI=7
- New HOMEPAGE
- Use _DEFAULT_SOURCE to suppress compiler warning

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Closes: https://bugs.gentoo.org/707224
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-mail/mboxgrep/files/mboxgrep-0.7.9-_DEFAULT_SOURCE.patch [new file with mode: 0644]
net-mail/mboxgrep/files/mboxgrep-0.7.9-fno-common.patch [new file with mode: 0644]
net-mail/mboxgrep/mboxgrep-0.7.9-r2.ebuild [new file with mode: 0644]
net-mail/mboxgrep/metadata.xml

diff --git a/net-mail/mboxgrep/files/mboxgrep-0.7.9-_DEFAULT_SOURCE.patch b/net-mail/mboxgrep/files/mboxgrep-0.7.9-_DEFAULT_SOURCE.patch
new file mode 100644 (file)
index 0000000..fe7ffec
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/misc.c
++++ b/src/misc.c
+@@ -19,7 +19,7 @@
+   $Id: misc.c,v 1.13 2003/04/06 21:01:49 dspiljar Exp $ */
+ #define _XOPEN_SOURCE  /* Pull in strptime(3) from time.h */
+-#define _BSD_SOURCE    /* Compensate for _XOPEN_SOURCE to pull in strdup(3)
++#define _DEFAULT_SOURCE    /* Compensate for _XOPEN_SOURCE to pull in strdup(3)
+                         * from string.h. */
+ #include <config.h>
diff --git a/net-mail/mboxgrep/files/mboxgrep-0.7.9-fno-common.patch b/net-mail/mboxgrep/files/mboxgrep-0.7.9-fno-common.patch
new file mode 100644 (file)
index 0000000..09c8388
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/src/mboxgrep.h
++++ b/src/mboxgrep.h
+@@ -129,6 +129,6 @@
+ }
+ option_t;
+-option_t config;
++extern option_t config;
+ #endif /* MBOXGREP_H */
+--- a/src/main.c
++++ b/src/main.c
+@@ -57,6 +57,7 @@
+ int count = 0;
+ void *tmpp;
+ checksum_t *cs;
++option_t config;
+ int
+ main (int argc, char **argv)
diff --git a/net-mail/mboxgrep/mboxgrep-0.7.9-r2.ebuild b/net-mail/mboxgrep/mboxgrep-0.7.9-r2.ebuild
new file mode 100644 (file)
index 0000000..5e42763
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Grep for mbox files"
+SRC_URI="mirror://sourceforge/mboxgrep/${P}.tar.gz"
+HOMEPAGE="https://datatipp.se/mboxgrep/"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dmalloc"
+
+RDEPEND="
+       app-arch/bzip2
+       dev-libs/libpcre
+       sys-libs/zlib
+       dmalloc? ( dev-libs/dmalloc )
+"
+DEPEND="
+       ${RDEPEND}
+"
+PATCHES=(
+       "${FILESDIR}"/${P}-_DEFAULT_SOURCE.patch
+       "${FILESDIR}"/${P}-fno-common.patch
+       "${FILESDIR}"/${P}-ldflags.patch
+)
+
+src_configure() {
+       econf \
+               $(use_with dmalloc no yes)
+}
+
+src_install() {
+       emake \
+               prefix="${D}"/usr \
+               mandir="${D}"/usr/share/man \
+               infodir="${D}"/usr/share/info \
+               install
+       dodoc ChangeLog NEWS TODO README
+}
index dff8618ac7eb7b92b967f307914222301163596b..63436f59f911d04d3172a95e241237367e4f864d 100644 (file)
@@ -2,6 +2,9 @@
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
        <!-- maintainer-needed -->
+<use>
+<flag name='dmalloc'>Enable debugging using <pkg>dev-libs/dmalloc</pkg></flag>
+</use>
        <upstream>
                <remote-id type="sourceforge">mboxgrep</remote-id>
        </upstream>