net-misc/eventd: Fix building with CFLAGS=-fno-common
authorJeroen Roovers <jer@gentoo.org>
Thu, 28 May 2020 07:46:09 +0000 (09:46 +0200)
committerJeroen Roovers <jer@gentoo.org>
Thu, 28 May 2020 07:53:40 +0000 (09:53 +0200)
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Closes: https://bugs.gentoo.org/707414
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-misc/eventd/eventd-0.27.0-r1.ebuild
net-misc/eventd/files/eventd-0.27.0-fno-common.patch [new file with mode: 0644]

index b0d6a59a9665c99e3c684a48c7ba76d57493ec75..5805963615d59227e84baae4c9c0899913081aec 100644 (file)
@@ -66,6 +66,9 @@ RDEPEND="${COMMON_DEPEND}
        net-libs/glib-networking[ssl]
 "
 BDEPEND="virtual/pkgconfig"
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.27.0-fno-common.patch
+)
 
 pkg_setup() {
        if use ipv6; then
diff --git a/net-misc/eventd/files/eventd-0.27.0-fno-common.patch b/net-misc/eventd/files/eventd-0.27.0-fno-common.patch
new file mode 100644 (file)
index 0000000..5f73166
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/plugins/nd/src/backend.h
++++ b/plugins/nd/src/backend.h
+@@ -37,7 +37,7 @@
+     _EVENTD_ND_BACKENDS_SIZE
+ } EventdNdBackends;
+-const gchar *eventd_nd_backends_names[_EVENTD_ND_BACKENDS_SIZE];
++extern const gchar *eventd_nd_backends_names[_EVENTD_ND_BACKENDS_SIZE];
+ typedef struct {
+     EventdNdContext *context;