net-news/liferea: fixed build against >=net-libs/webkit-gtk-2.26.2
authorYuri Konotopov <ykonotopov@gnome.org>
Mon, 6 Jan 2020 06:58:12 +0000 (10:58 +0400)
committerMichał Górny <mgorny@gentoo.org>
Mon, 6 Jan 2020 14:04:25 +0000 (15:04 +0100)
Closes: https://bugs.gentoo.org/704594
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Yuri Konotopov <ykonotopov@gnome.org>
Closes: https://github.com/gentoo/gentoo/pull/14257
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-news/liferea/liferea-1.12.3.ebuild
net-news/liferea/liferea-1.12.7.ebuild

index 8cd6e8a1b5de202a2850ab3b04f89356f2be9a0d..523c5692039b971eb6ec189ea511257d4059d341 100644 (file)
@@ -43,6 +43,13 @@ src_configure() {
        gnome2_src_configure --disable-schemas-compile
 }
 
+src_compile() {
+       # Workaround crash in libwebkit2gtk-4.0.so
+       # https://bugs.gentoo.org/704594
+       WEBKIT_DISABLE_COMPOSITING_MODE=1 \
+                gnome2_src_compile
+}
+
 src_install() {
        gnome2_src_install
 
index 370391a17c9af3babac0533fcc9c388ef7326d46..15e84f1529bbe4aa3b2d8cfa23262102df8bc4a5 100644 (file)
@@ -34,6 +34,13 @@ DEPEND="${RDEPEND}
        dev-util/intltool
        virtual/pkgconfig"
 
+src_compile() {
+       # Workaround crash in libwebkit2gtk-4.0.so
+       # https://bugs.gentoo.org/704594
+       WEBKIT_DISABLE_COMPOSITING_MODE=1 \
+               gnome2_src_compile
+}
+
 pkg_postinst() {
        gnome2_pkg_postinst