net-fs/nfs-utils: Bump to version 2.4.3
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 11 Feb 2020 10:30:19 +0000 (11:30 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 11 Feb 2020 10:30:29 +0000 (11:30 +0100)
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-fs/nfs-utils/Manifest
net-fs/nfs-utils/nfs-utils-2.4.3.ebuild [new file with mode: 0644]

index a752daf434b75a2d3e88e874f22d955d92cc969a..87497d2adaf373e0a52b3ee1e3c5f17a8fc703e0 100644 (file)
@@ -1,3 +1,4 @@
 DIST nfs-utils-2.3.4.tar.bz2 906900 BLAKE2B 968fac7b37c7311bc8d29667c88db925aac0c062ed7ef8c13f9e5c11c3c88960ffaea56c1b6cfb5594a01238f9190e55ab7b837a79a7a804bc55dcca75908eea SHA512 25203b38be6683f25ad6583ac8534873c907124092a768955c1454899e2f467b9dd427b167556eb4f28992b5720da13078eb1eb086da991438454f268e1559a5
 DIST nfs-utils-2.4.1.tar.bz2 910791 BLAKE2B 4419eff7fca21747e0bc4969ebb8a8b863aa951984af8f23f197e7dfc4faad3770173808862b84178714ca75f021be1af96f9e4408fecd7ef97999d261f2f21b SHA512 655a115955f35177b761f821e29c752693d614f4c6c2a90d392e0ab83b615247a397cf18e8ad453a93c6dc528d1fa90cfdf8b04de6626e0f4083b10e2e54f540
 DIST nfs-utils-2.4.2.tar.bz2 918576 BLAKE2B a1dba3ae2e58794509ea7907d80e40fc49a0c5e72019222ba16daa74aa757cab5e6fde9ed066f6b5f379b40dbd61622a05fcafc298a79231e417ab2086127278 SHA512 f9724ff2ac185e6c29afd577b33da38b1d11803af1ccb905cd615afa3383c6ac7a3fa4e0f43ea8d062e9aedcdbae90adc9b55ae9d0abe4731f69aa3a6f8d2534
+DIST nfs-utils-2.4.3.tar.bz2 921710 BLAKE2B 9386a99561370e09ffe871ec38a4fc993e99332c0c6fdb0d07eb7a924cfab4634e5c5186ac1f1629deecf02557fd2d3d5d99b90d97c32d3680ca4478b5c49d9c SHA512 160c828dd7a7b3206b7f167eb99a8dfac7e1a0c8dd88c81b639c3a1f66916908b3ca11fb9a945e4cf6a474f82509ed91a8a3217623f6cb79302d3d9b760f19d9
diff --git a/net-fs/nfs-utils/nfs-utils-2.4.3.ebuild b/net-fs/nfs-utils/nfs-utils-2.4.3.ebuild
new file mode 100644 (file)
index 0000000..acb9806
--- /dev/null
@@ -0,0 +1,204 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic linux-info multilib systemd
+
+DESCRIPTION="NFS client and server daemons"
+HOMEPAGE="http://linux-nfs.org/"
+
+if [[ "${PV}" = *_rc* ]] ; then
+       MY_PV="$(ver_rs 1- -)"
+       SRC_URI="http://git.linux-nfs.org/?p=steved/nfs-utils.git;a=snapshot;h=refs/tags/${PN}-${MY_PV};sf=tgz -> ${P}.tar.gz"
+       S="${WORKDIR}/${PN}-${PN}-${MY_PV}"
+else
+       SRC_URI="mirror://sourceforge/nfs/${P}.tar.bz2"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="caps ipv6 junction kerberos ldap +libmount nfsdcld +nfsidmap +nfsv4 nfsv41 selinux tcpd +uuid"
+REQUIRED_USE="kerberos? ( nfsv4 )"
+RESTRICT="test" #315573
+
+# kth-krb doesn't provide the right include
+# files, and nfs-utils doesn't build against heimdal either,
+# so don't depend on virtual/krb.
+# (04 Feb 2005 agriffis)
+DEPEND="
+       >=dev-db/sqlite-3.3
+       dev-libs/libxml2
+       net-libs/libtirpc:=
+       >=net-nds/rpcbind-0.2.4
+       sys-libs/e2fsprogs-libs
+       caps? ( sys-libs/libcap )
+       ldap? ( net-nds/openldap )
+       libmount? ( sys-apps/util-linux )
+       nfsv4? (
+               dev-libs/libevent:=
+               >=sys-apps/keyutils-1.5.9:=
+               kerberos? (
+                       >=net-libs/libtirpc-0.2.4-r1[kerberos]
+                       app-crypt/mit-krb5
+               )
+       )
+       nfsv41? (
+               sys-fs/lvm2
+       )
+       tcpd? ( sys-apps/tcp-wrappers )
+       uuid? ( sys-apps/util-linux )"
+RDEPEND="${DEPEND}
+       !net-libs/libnfsidmap
+       !net-nds/portmap
+       !<sys-apps/openrc-0.13.9
+       selinux? (
+               sec-policy/selinux-rpc
+               sec-policy/selinux-rpcbind
+       )
+"
+BDEPEND="
+       net-libs/rpcsvc-proto
+       virtual/pkgconfig
+"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.4.2-no-werror.patch
+       "${FILESDIR}"/${PN}-2.4.2-Ensure-consistent-struct-stat.patch
+)
+
+pkg_setup() {
+       linux-info_pkg_setup
+       if use nfsv4 && ! use nfsdcld && linux_config_exists && ! linux_chkconfig_present CRYPTO_MD5 ; then
+               ewarn "Your NFS server will be unable to track clients across server restarts!"
+               ewarn "Please enable the \"${HILITE}nfsdcld${NORMAL}\" USE flag to install the nfsdcltrack usermode"
+               ewarn "helper upcall program, or enable ${HILITE}CONFIG_CRYPTO_MD5${NORMAL} in your kernel to"
+               ewarn "support the legacy, in-kernel client tracker."
+       fi
+}
+
+src_prepare() {
+       default
+
+       sed \
+               -e "/^sbindir/s:= := \"${EPREFIX}\":g" \
+               -i utils/*/Makefile.am || die
+
+       eautoreconf
+}
+
+src_configure() {
+       export libsqlite3_cv_is_recent=yes # Our DEPEND forces this.
+       export ac_cv_header_keyutils_h=$(usex nfsidmap)
+       local myeconfargs=(
+               --with-statedir="${EPREFIX}"/var/lib/nfs
+               --enable-tirpc
+               --with-tirpcinclude="${EPREFIX}"/usr/include/tirpc/
+               --with-pluginpath="${EPREFIX}"/usr/$(get_libdir)/libnfsidmap
+               --with-rpcgen
+               --with-systemd="$(systemd_get_systemunitdir)"
+               --without-gssglue
+               $(use_enable caps)
+               $(use_enable ipv6)
+               $(use_enable junction)
+               $(use_enable kerberos gss)
+               $(use_enable kerberos svcgss)
+               $(use_enable ldap)
+               $(use_enable libmount libmount-mount)
+               $(use_enable nfsdcld nfsdcltrack)
+               $(use_enable nfsv4)
+               $(use_enable nfsv41)
+               $(use_enable uuid)
+               $(use_with tcpd tcp-wrappers)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_compile(){
+       # remove compiled files bundled in the tarball
+       emake clean
+       default
+}
+
+src_install() {
+       default
+       rm linux-nfs/Makefile* || die
+       dodoc -r linux-nfs README
+
+       # Don't overwrite existing xtab/etab, install the original
+       # versions somewhere safe...  more info in pkg_postinst
+       keepdir /var/lib/nfs/{,sm,sm.bak}
+       mv "${ED}"/var/lib/nfs "${ED}"/usr/$(get_libdir)/ || die
+
+       # Install some client-side binaries in /sbin
+       dodir /sbin
+       mv "${ED}"/usr/sbin/rpc.statd "${ED}"/sbin/ || die
+
+       if use nfsv4 && use nfsidmap ; then
+               insinto /etc
+               doins support/nfsidmap/idmapd.conf
+
+               # Install a config file for idmappers in newer kernels. #415625
+               insinto /etc/request-key.d
+               echo 'create id_resolver * * /usr/sbin/nfsidmap -t 600 %k %d' > id_resolver.conf
+               doins id_resolver.conf
+       fi
+
+       insinto /etc
+       doins "${FILESDIR}"/exports
+       keepdir /etc/exports.d
+
+       local f list=() opt_need=""
+       if use nfsv4 ; then
+               opt_need="rpc.idmapd"
+               list+=( rpc.idmapd rpc.pipefs )
+               use kerberos && list+=( rpc.gssd rpc.svcgssd )
+       fi
+       for f in nfs nfsclient rpc.statd "${list[@]}" ; do
+               newinitd "${FILESDIR}"/${f}.initd ${f}
+       done
+       newinitd "${FILESDIR}"/nfsmount.initd-1.3.1 nfsmount # Nuke after 2015/08/01
+       for f in nfs nfsclient ; do
+               newconfd "${FILESDIR}"/${f}.confd ${f}
+       done
+       sed -i \
+               -e "/^NFS_NEEDED_SERVICES=/s:=.*:=\"${opt_need}\":" \
+               "${ED}"/etc/conf.d/nfs || die #234132
+
+       local systemd_systemunitdir="$(systemd_get_systemunitdir)"
+       sed -i \
+               -e 's:/usr/sbin/rpc.statd:/sbin/rpc.statd:' \
+               "${ED}${systemd_systemunitdir}"/* || die
+
+       keepdir /var/lib/nfs #368505
+       keepdir /var/lib/nfs/v4recovery #603628
+
+}
+
+pkg_postinst() {
+       # Install default xtab and friends if there's none existing.  In
+       # src_install we put them in /usr/lib/nfs for safe-keeping, but
+       # the daemons actually use the files in /var/lib/nfs.  #30486
+       local f
+       for f in "${EROOT}"/usr/$(get_libdir)/nfs/*; do
+               [[ -e ${EROOT}/var/lib/nfs/${f##*/} ]] && continue
+               einfo "Copying default ${f##*/} from ${EPREFIX}/usr/$(get_libdir)/nfs to ${EPREFIX}/var/lib/nfs"
+               cp -pPR "${f}" "${EROOT}"/var/lib/nfs/
+       done
+
+       if systemd_is_booted; then
+               for v in ${REPLACING_VERSIONS}; do
+                       if ver_test "${v}" -lt 1.3.0; then
+                               ewarn "We have switched to upstream systemd unit files. Since"
+                               ewarn "they got renamed, you should probably enable the new ones."
+                               ewarn "You can run 'equery files nfs-utils | grep systemd'"
+                               ewarn "to know what services you need to enable now."
+                       fi
+               done
+       else
+               ewarn "If you use OpenRC, the nfsmount service has been replaced with nfsclient."
+               ewarn "If you were using nfsmount, please add nfsclient and netmount to the"
+               ewarn "same runlevel as nfsmount."
+       fi
+}