x11-misc/sct: version bump.
authorPatrice Clement <monsieurp@gentoo.org>
Mon, 13 Apr 2020 09:39:51 +0000 (11:39 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 13 Apr 2020 09:40:08 +0000 (11:40 +0200)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
x11-misc/sct/Manifest
x11-misc/sct/sct-0.5.ebuild [new file with mode: 0644]

index 4f034a61b774cce07d5dac576c0aaef3beb66985..7743791257896ace1a1a840efd1373cd77311600 100644 (file)
@@ -1 +1,2 @@
 DIST sct-0.4.tar.gz 4560 BLAKE2B a7434499d43180a20e4345ad207cd7644dd7271f9d1a3929e797263f5580e9f7517a3cb86a65892b68a1619a29cc5bb846fa40e3e8c14f4f5a5a7ab65dfa5ca1 SHA512 7a556c2d26cb2389a3e38e74de992d3fac96b29c637e20d1307e0ea0985c1119a3d05f2108d338612b407f5b5f5362bd3e5582722878d7ae62c568bdc9f46e65
+DIST sct-0.5.tar.gz 4802 BLAKE2B 2a7d522031f159b2a8d8d8b63603ff4094d6726d92ad7ac1675c8fbc4c716a8c8b1ae6fbc12d3fe5238552621ebbbc4416658ac89610d40010bf1560446fc55d SHA512 15f2013e3c6c56ff50078f1aa070b3388e07a780d14e5664542ea47e51e8eb84e937927467bf9ed74127a7382dea16c5ca94d255c8aeaaa696c9a81ca658f4a2
diff --git a/x11-misc/sct/sct-0.5.ebuild b/x11-misc/sct/sct-0.5.ebuild
new file mode 100644 (file)
index 0000000..615b8b6
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Set color temperature of the screen"
+HOMEPAGE="https://www.umaxx.net/"
+SRC_URI="https://www.umaxx.net/dl/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="
+       x11-libs/libXrender
+       x11-libs/libXrandr
+       x11-libs/libXdmcp
+       x11-libs/libXext
+       x11-libs/libX11
+       x11-libs/libXau
+       x11-libs/libxcb
+       dev-libs/libbsd"
+
+RDEPEND="
+       ${DEPEND}"
+
+src_prepare() {
+       default
+       sed \
+               -e 's:_BSD_SOURCE:_DEFAULT_SOURCE:g' \
+               -i Makefile || die
+}
+
+src_install() {
+       dobin "${PN}"
+       doman "${PN}.1"
+       einstalldocs
+}