dev-ruby/actiontext: add 6.0.3.1
authorHans de Graaff <graaff@gentoo.org>
Mon, 18 May 2020 18:42:22 +0000 (20:42 +0200)
committerHans de Graaff <graaff@gentoo.org>
Mon, 18 May 2020 18:45:11 +0000 (20:45 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/actiontext/Manifest
dev-ruby/actiontext/actiontext-6.0.3.1.ebuild [new file with mode: 0644]

index a3c05dd3c74ff4c8cb2b1421df2be5a8cbdb3715..e2433ae67e484d11a2077ef8b46b4f217a47e8f6 100644 (file)
@@ -1,2 +1,3 @@
 DIST rails-6.0.2.2.tgz 18556125 BLAKE2B f4ed5cc6cbbfa84fb687aba5a6c8f2f6ab68febb41147c40ed8dbc6253c128adbac6503e65e89fe672f50270716d197d8c05b4e1e286aafd76581fc167e6c5da SHA512 c1aab2d6c72948c75a047aec9d9f651f0c1bae78bb17e2fa0cb393113ee1e59980dc093e6f3fd3b2f3839c9b3bb4afcd0b0badfd9574b35b932275a9d9800689
+DIST rails-6.0.3.1.tgz 18567937 BLAKE2B fe6b58c2cb389f766d356f983787ddd602ee835e90cdbe26c25586c1304aa8c80d4ace2e0956326c0dd428dcd51a624d68d64667c2294c326779498a809ea6c9 SHA512 fcdaff0b0e4877a53f89b2b69c9271213297db8df8abccd071da5f2b2d3e3e6855914e1059596903f761b9a3891b31c2fdf10e887183f4433b260f84c4ebccdf
 DIST rails-6.0.3.tgz 18565682 BLAKE2B fe8601aec070535f487801eec16d944809be824e4833b7a906b47b4099dd5e72515ac3e492e4301dd651657fc2c4547ecbdd2c12265e04aad2758e9e284ad385 SHA512 f4572b4ebba9a79a6910c554f06e71efab5ccc0090e1a620e80b9d3b479cdd21d5a041437d90313e045e47ccc6e44eb21d4e56cc9fe1fb791cf5593427d0501b
diff --git a/dev-ruby/actiontext/actiontext-6.0.3.1.ebuild b/dev-ruby/actiontext/actiontext-6.0.3.1.ebuild
new file mode 100644 (file)
index 0000000..81ba032
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="actiontext.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRAINSTALL="app db package.json"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Edit and display rich text in Rails applications"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+       ~dev-ruby/actionpack-${PV}
+       ~dev-ruby/activerecord-${PV}
+       ~dev-ruby/activestorage-${PV}
+       ~dev-ruby/activesupport-${PV}
+       >=dev-ruby/nokogiri-1.8.5
+"
+
+ruby_add_bdepend "test? (
+       dev-ruby/mocha
+)"
+
+all_ruby_prepare() {
+       # Remove items from the common Gemfile that we don't need for this
+       # test run. This also requires handling some gemspecs.
+       sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\)/ s:^:#:" \
+               -e '/:job/,/end/ s:^:#:' \
+               -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+       rm ../Gemfile.lock || die
+}
+
+each_ruby_prepare() {
+       sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
+}