media-libs/zimg: tweak for gcc-10, bug #721676
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 9 May 2020 09:36:19 +0000 (10:36 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 9 May 2020 09:36:33 +0000 (10:36 +0100)
The build fails as:

```
src/zimg/colorspace/matrix3.cpp:20:7:
  error: 'size_t' was not declared in this scope; did you mean 'std::size_t'?
   20 |  for (size_t i = 0; i < 3; ++i) {
      |       ^~~~~~
      |       std::size_t
```

Direct backport of upstream 9ae36d7d5f74 ("Update matrix3.cpp")
which adds missing <cstddef> include needed for 'size_t'.

Reported-by: Patrick McLean
Closes: https://bugs.gentoo.org/721676
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
media-libs/zimg/files/zimg-2.9.2-gcc-10.patch [new file with mode: 0644]
media-libs/zimg/zimg-2.9.2.ebuild

diff --git a/media-libs/zimg/files/zimg-2.9.2-gcc-10.patch b/media-libs/zimg/files/zimg-2.9.2-gcc-10.patch
new file mode 100644 (file)
index 0000000..ea192f7
--- /dev/null
@@ -0,0 +1,18 @@
+https://bugs.gentoo.org/721676
+
+From 9ae36d7d5f7420eaacd9644451933512fa13d716 Mon Sep 17 00:00:00 2001
+From: sekrit-twc <sekrit-twc@users.noreply.github.com>
+Date: Wed, 4 Dec 2019 12:01:26 -0800
+Subject: [PATCH] Update matrix3.cpp
+
+---
+ src/zimg/colorspace/matrix3.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/src/zimg/colorspace/matrix3.cpp
++++ b/src/zimg/colorspace/matrix3.cpp
+@@ -1,3 +1,4 @@
++#include <cstddef>
+ #include "matrix3.h"
+ namespace zimg {
index c1295123848eec2a6b5f3208c08802166f2885f8..e962d7a4b5f73b112da8605d40cf1fa83730b2bf 100644 (file)
@@ -20,6 +20,8 @@ LICENSE="WTFPL-2"
 SLOT="0"
 IUSE="cpu_flags_x86_sse debug static-libs"
 
+PATCHES=("${FILESDIR}"/${PN}-2.9.2-gcc-10.patch)
+
 src_prepare() {
        default
        eautoreconf