games-strategy/colobot: Workaround the Ninja build problem
authorMichał Górny <mgorny@gentoo.org>
Tue, 24 Sep 2019 14:42:19 +0000 (16:42 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 24 Sep 2019 14:42:40 +0000 (16:42 +0200)
Call po4a early in order to provide files required for manpage builds.
Those files are normally provided implicitly by dependant target call
but that is not good enough for Ninja.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
games-strategy/colobot/colobot-0.1.12.ebuild
games-strategy/colobot/colobot-9999.ebuild

index 3c3762f6152102bfe9e53a37a144a047b5e826bd..1611ef4a1d61fdb96b93ec61097463bf3e69bf44 100644 (file)
@@ -3,8 +3,6 @@
 
 EAPI=7
 
-# upstream CMakeLists.txt are buggy
-CMAKE_MAKEFILE_GENERATOR=emake
 inherit cmake-utils desktop xdg-utils
 
 DESCRIPTION="Colobot is an educational real-time strategy video game featuring 3D graphics"
@@ -18,6 +16,11 @@ KEYWORDS="~amd64"
 IUSE="devbuild doc +openal test tools"
 RESTRICT="!test? ( test )"
 
+# perl for pod2man
+BDEPEND="
+       app-text/po4a
+       dev-lang/perl
+       sys-devel/gettext"
 DEPEND="
        dev-games/physfs
        dev-libs/boost:=
@@ -30,11 +33,18 @@ DEPEND="
        media-libs/sdl2-image
        media-libs/sdl2-ttf
        media-sound/vorbis-tools
-       sys-devel/gettext
        openal? ( media-libs/openal )"
 RDEPEND="${DEPEND}
        games-strategy/colobot-data"
 
+src_prepare() {
+       cmake-utils_src_prepare
+
+       # we need to call it explicitly to help Ninja figure out the deps
+       cd desktop || die
+       po4a po4a.cfg || die
+}
+
 src_configure() {
        local mycmakeargs=(
                -DDEV_BUILD=$(usex devbuild)
index b4179756b903b6dfacc7e555b804c9817f5437fd..49d5ea90727ed2e3af16e31284d0fcf257aa0377 100644 (file)
@@ -3,8 +3,6 @@
 
 EAPI=7
 
-# upstream CMakeLists.txt are buggy
-CMAKE_MAKEFILE_GENERATOR=emake
 inherit cmake-utils desktop git-r3 xdg-utils
 
 DESCRIPTION="Colobot is an educational real-time strategy video game featuring 3D graphics"
@@ -12,12 +10,17 @@ HOMEPAGE="https://colobot.info/"
 EGIT_REPO_URI="https://github.com/colobot/colobot"
 EGIT_SUBMODULES=()
 
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
 SLOT="0"
 KEYWORDS=""
 IUSE="devbuild doc +openal test tools"
 RESTRICT="!test? ( test )"
 
+# perl for pod2man
+BDEPEND="
+       app-text/po4a
+       dev-lang/perl
+       sys-devel/gettext"
 DEPEND="
        dev-games/physfs
        dev-libs/boost:=
@@ -30,11 +33,18 @@ DEPEND="
        media-libs/sdl2-image
        media-libs/sdl2-ttf
        media-sound/vorbis-tools
-       sys-devel/gettext
        openal? ( media-libs/openal )"
 RDEPEND="${DEPEND}
        games-strategy/colobot-data"
 
+src_prepare() {
+       cmake-utils_src_prepare
+
+       # we need to call it explicitly to help Ninja figure out the deps
+       cd desktop || die
+       po4a po4a.cfg || die
+}
+
 src_configure() {
        local mycmakeargs=(
                -DDEV_BUILD=$(usex devbuild)