dev-libs/libunistring: marked *-macos, *-solaris
authorFabian Groffen <grobian@gentoo.org>
Tue, 24 Jan 2017 09:47:00 +0000 (10:47 +0100)
committerFabian Groffen <grobian@gentoo.org>
Tue, 24 Jan 2017 09:57:32 +0000 (10:57 +0100)
Package-Manager: portage-2.3.0

dev-libs/libunistring/libunistring-0.9.7.ebuild

index 0c3ababd6959e2c0d56a02f40c5059f4fdaa6db2..88b56233dc3a413773c0725476dee7b19f70c5e0 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=6
 
-inherit eutils multilib-minimal
+inherit eutils multilib-minimal libtool
 
 DESCRIPTION="Library for manipulating Unicode strings and C strings according to the Unicode standard"
 HOMEPAGE="https://www.gnu.org/software/libunistring/"
@@ -12,13 +12,18 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
 
 LICENSE="LGPL-3 GPL-3"
 SLOT="0/2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
 IUSE="doc static-libs"
 
 PATCHES=(
        "${FILESDIR}"/${PN}-nodocs.patch
 )
 
+src_prepare() {
+       default
+       elibtoolize  # for Solaris shared libraries
+}
+
 multilib_src_configure() {
        ECONF_SOURCE="${S}" \
        econf $(use_enable static-libs static)