app-eselect/eselect-sh: Remove posh from targets
authorMichał Górny <mgorny@gentoo.org>
Sun, 17 May 2020 13:35:35 +0000 (15:35 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 17 May 2020 13:36:36 +0000 (15:36 +0200)
Closes: https://bugs.gentoo.org/720996
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-eselect/eselect-sh/eselect-sh-0.4.1.ebuild [new file with mode: 0644]
app-eselect/eselect-sh/files/sh.eselect-0.4.1 [new file with mode: 0644]

diff --git a/app-eselect/eselect-sh/eselect-sh-0.4.1.ebuild b/app-eselect/eselect-sh/eselect-sh-0.4.1.ebuild
new file mode 100644 (file)
index 0000000..2d22ada
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Manages the /bin/sh (POSIX shell) symlink"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI=""
+S=${WORKDIR}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="app-eselect/eselect-lib-bin-symlink"
+
+src_install() {
+       insinto /usr/share/eselect/modules
+       newins "${FILESDIR}"/sh.eselect-${PV} sh.eselect
+}
diff --git a/app-eselect/eselect-sh/files/sh.eselect-0.4.1 b/app-eselect/eselect-sh/files/sh.eselect-0.4.1
new file mode 100644 (file)
index 0000000..286c321
--- /dev/null
@@ -0,0 +1,13 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Manage /bin/sh (POSIX shell) implementations"
+MAINTAINER="mgorny@gentoo.org"
+VERSION="0.4.1"
+
+SYMLINK_PATH=/bin/sh
+SYMLINK_TARGETS=( bash dash mksh )
+SYMLINK_DESCRIPTION='POSIX shell'
+SYMLINK_CRUCIAL=1
+
+inherit bin-symlink