x11-terms/qterminal: add version 0.15.0
authorJimi Huotari <chiitoo@gentoo.org>
Mon, 27 Apr 2020 18:14:23 +0000 (21:14 +0300)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 20 May 2020 23:28:28 +0000 (01:28 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
x11-terms/qterminal/Manifest
x11-terms/qterminal/qterminal-0.15.0.ebuild [new file with mode: 0644]

index 262346b315cf9c7949d64b517fa49046c04262fb..a6294ea31eb7ebc9e226fd9f8f78c0ad1502d0a0 100644 (file)
@@ -1 +1,2 @@
 DIST qterminal-0.14.1.tar.xz 167520 BLAKE2B e496e53b1855f94c49ef5fe699d7c88ca8ad4da40eb24f87701e72c50982bc98a16f060b075597a99d105d32dd38790e6599cd5b36d2901ffe1f72d0114f0fba SHA512 bb9ac6519236bb834892c1be50bc27f86631b2c7ed60c1ddd4300fedd48f3ea8a08aa453fa03199693486159f667f9391af9491dea5402b4f807ee91e8a6e5cf
+DIST qterminal-0.15.0.tar.xz 179608 BLAKE2B 7569f408c7edf16090907bf6386d4b87fbe5c9f27b738db38eda528ec3390470bc24cadd3bce8e60439b928b611d0208ba8b53172b8fc0b2af11307780041904 SHA512 03c690fd090fc87e0475f5a34e19ff1d5aeaea146fe5c62aa09540b6abfa0363506c44c3e82c5d3957e351b883ac9fdd014da66ce7d44e7d3e5fecc8fcd7bcac
diff --git a/x11-terms/qterminal/qterminal-0.15.0.ebuild b/x11-terms/qterminal/qterminal-0.15.0.ebuild
new file mode 100644 (file)
index 0000000..2c670ee
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt-based multitab terminal emulator"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+       SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.7.0"
+DEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtdbus:5
+       dev-qt/qtgui:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtx11extras:5
+       x11-libs/libX11
+       ~x11-libs/qtermwidget-${PV}
+"
+RDEPEND="${DEPEND}
+       !lxqt-base/lxqt-l10n
+"
+
+pkg_postinst() {
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}