games-strategy/lightyears: Fix dependencies, https, EAPI 7
authorJames Le Cuirot <chewi@gentoo.org>
Fri, 2 Aug 2019 21:20:31 +0000 (22:20 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Fri, 2 Aug 2019 21:42:45 +0000 (22:42 +0100)
Closes: https://bugs.gentoo.org/685662
Package-Manager: Portage-2.3.70, Repoman-2.3.16
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-strategy/lightyears/lightyears-1.4-r3.ebuild [moved from games-strategy/lightyears/lightyears-1.4-r2.ebuild with 66% similarity]

similarity index 66%
rename from games-strategy/lightyears/lightyears-1.4-r2.ebuild
rename to games-strategy/lightyears/lightyears-1.4-r3.ebuild
index 7e7344951fc205bac91c6bdf54e7d5dfb336b042..4d4cfa964e45a2a4db5279ef23424c662ffdf7db 100644 (file)
@@ -1,34 +1,37 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
+
 PYTHON_COMPAT=( python2_7 )
 
-inherit desktop python-single-r1
+inherit desktop python-single-r1 xdg-utils
 
 DESCRIPTION="A single-player game with a science-fiction theme"
-HOMEPAGE="http://www.jwhitham.org/20kly/"
-SRC_URI="http://www.jwhitham.org/20kly/${P}.tar.bz2"
-
+HOMEPAGE="https://www.jwhitham.org/20kly/"
+SRC_URI="https://www.jwhitham.org/20kly/${P}.tar.bz2"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-
-IUSE=""
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RDEPEND="${PYTHON_DEPS}
        dev-python/pygame[${PYTHON_USEDEP}]
 "
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+       "${FILESDIR}/${P}"-gentoo.patch
+)
 
 src_prepare() {
        default
-       eapply "${FILESDIR}/${P}"-gentoo.patch
+
        sed -i \
                -e "s:@GENTOO_LIBDIR@:/usr/$(get_libdir)/${PN}:" \
                -e "s:@GENTOO_DATADIR@:/usr/share/${PN}:" \
                ${PN} || die
+
        python_fix_shebang .
 }
 
@@ -48,3 +51,6 @@ src_install() {
        newicon data/32.png ${PN}.png
        make_desktop_entry ${PN} "Light Years Into Space"
 }
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }