net-libs/nodejs: Call xdg_environment_reset() from xdg-utils.eclass
authorJeroen Roovers <jer@gentoo.org>
Fri, 11 Oct 2019 14:50:11 +0000 (16:50 +0200)
committerJeroen Roovers <jer@gentoo.org>
Fri, 11 Oct 2019 14:53:09 +0000 (16:53 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Bug: https://bugs.gentoo.org/625982
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-libs/nodejs/nodejs-10.16.3.ebuild
net-libs/nodejs/nodejs-12.10.0.ebuild
net-libs/nodejs/nodejs-12.11.1.ebuild
net-libs/nodejs/nodejs-8.12.0.ebuild
net-libs/nodejs/nodejs-8.16.1.ebuild
net-libs/nodejs/nodejs-8.16.2.ebuild
net-libs/nodejs/nodejs-99999999.ebuild

index c2c2f3af8c6d093460bf5411e307b4515910d627..4dfee5eb4434815a6fb4c8b42111ec817a827af6 100644 (file)
@@ -6,7 +6,7 @@ EAPI=6
 PYTHON_COMPAT=( python2_7 )
 PYTHON_REQ_USE="threads"
 
-inherit bash-completion-r1 eutils flag-o-matic pax-utils python-any-r1 toolchain-funcs
+inherit bash-completion-r1 eutils flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
 
 DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
 HOMEPAGE="https://nodejs.org/"
@@ -92,6 +92,8 @@ src_prepare() {
 }
 
 src_configure() {
+       xdg_environment_reset
+
        local myconf=( --shared-cares --shared-http-parser --shared-libuv --shared-nghttp2 --shared-zlib )
        use debug && myconf+=( --debug )
        use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
index 7cc1a7dd9a62c1eeec9af86690ae5d9ef43c138a..7a072e08f8c175d6db60a3827a3b91e574a5d941 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 PYTHON_COMPAT=( python2_7 )
 PYTHON_REQ_USE="threads"
-inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs
+inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
 
 DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
 HOMEPAGE="https://nodejs.org/"
@@ -90,6 +90,8 @@ src_prepare() {
 }
 
 src_configure() {
+       xdg_environment_reset
+
        local myconf=(
                --shared-cares --shared-http-parser --shared-libuv --shared-nghttp2
                --shared-zlib
index 47b66d3609c143b4ccd85bdeaa42b33ff7d91150..fdf342ca0430b8a67b683a64f090b9554add046e 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 PYTHON_COMPAT=( python2_7 )
 PYTHON_REQ_USE="threads"
-inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs
+inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
 
 DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
 HOMEPAGE="https://nodejs.org/"
@@ -92,6 +92,8 @@ src_prepare() {
 }
 
 src_configure() {
+       xdg_environment_reset
+
        local myconf=(
                --shared-cares --shared-http-parser --shared-libuv --shared-nghttp2
                --shared-zlib
index ed7e641f54afa2682dd3adc1c995ef20f74f5b5b..2e98f86fe29f2a80d7d5f324affdb36e6299aa12 100644 (file)
@@ -7,7 +7,7 @@ RESTRICT="test"
 PYTHON_COMPAT=( python2_7 )
 PYTHON_REQ_USE="threads"
 
-inherit bash-completion-r1 eutils flag-o-matic pax-utils python-any-r1 toolchain-funcs
+inherit bash-completion-r1 eutils flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
 
 DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
 HOMEPAGE="https://nodejs.org/"
@@ -92,6 +92,8 @@ src_prepare() {
 }
 
 src_configure() {
+       xdg_environment_reset
+
        local myconf=( --shared-http-parser --shared-libuv --shared-nghttp2 --shared-zlib )
        use debug && myconf+=( --debug )
        use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
index fa36bb45c983417db0441cb8e8306048c3e45e97..fb4226a9a9d07145f4565fde584a4aa631897230 100644 (file)
@@ -7,7 +7,7 @@ RESTRICT="test"
 PYTHON_COMPAT=( python2_7 )
 PYTHON_REQ_USE="threads"
 
-inherit bash-completion-r1 eutils flag-o-matic pax-utils python-any-r1 toolchain-funcs
+inherit bash-completion-r1 eutils flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
 
 DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
 HOMEPAGE="https://nodejs.org/"
@@ -97,6 +97,8 @@ src_prepare() {
 }
 
 src_configure() {
+       xdg_environment_reset
+
        local myconf=( --shared-cares --shared-http-parser --shared-libuv --shared-nghttp2 --shared-zlib )
        use debug && myconf+=( --debug )
        use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
index 8c46805762d17e276fbc7d30d0948c3cecf7dfb2..621189a0947e25d562e6ddad40c518608600b405 100644 (file)
@@ -6,7 +6,7 @@ EAPI=7
 PYTHON_COMPAT=( python2_7 )
 PYTHON_REQ_USE="threads"
 
-inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs
+inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
 
 DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
 HOMEPAGE="https://nodejs.org/"
@@ -97,6 +97,8 @@ src_prepare() {
 }
 
 src_configure() {
+       xdg_environment_reset
+
        local myconf=( --shared-cares --shared-http-parser --shared-libuv --shared-nghttp2 --shared-zlib )
        use debug && myconf+=( --debug )
        use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
index 8f2196a20c61e7e90db1715fc7ade0dc438ca3a5..098bb9968f85200ead87c3a71514bdf887297899 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 PYTHON_COMPAT=( python2_7 )
 PYTHON_REQ_USE="threads"
-inherit bash-completion-r1 flag-o-matic git-r3 pax-utils python-any-r1 toolchain-funcs
+inherit bash-completion-r1 flag-o-matic git-r3 pax-utils python-any-r1 toolchain-funcs xdg-utils
 
 DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
 HOMEPAGE="https://nodejs.org/"
@@ -89,6 +89,8 @@ src_prepare() {
 }
 
 src_configure() {
+       xdg_environment_reset
+
        local myconf=(
                --shared-cares --shared-http-parser --shared-libuv --shared-nghttp2
                --shared-zlib