dev-libs/libinput: Bump to version 1.13.2
authorLars Wendler <polynomial-c@gentoo.org>
Sat, 11 May 2019 08:44:50 +0000 (10:44 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Sat, 11 May 2019 08:46:33 +0000 (10:46 +0200)
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
dev-libs/libinput/Manifest
dev-libs/libinput/libinput-1.13.2.ebuild [new file with mode: 0644]

index 10b2073f82b78d30e31c4040ba3e2be156b4fec0..a9c2b21dfbebdc01553237ae65aa451f7a932ca4 100644 (file)
@@ -1,3 +1,4 @@
 DIST libinput-1.12.6.tar.xz 518784 BLAKE2B 7462f47be3628f9c66ef5b7c8265b588bd0ca328bafe91932f5341a010ac882648b4e7cfd0db241ae526836172e0829d68d21f8966d2be8b49f4e1c0c40df018 SHA512 02ad90c77a0c8c27fd96ec34e1546c5f0947ced49bad386372c1ef7c41b3b2157c39020f0766f20aaf2ab3c97128567e169279bea21115ced39499dda325d2ef
 DIST libinput-1.13.0.tar.xz 529912 BLAKE2B 830dca7387c6527ebdf41e8b01bf9d8df094ec2309e229e3933b56217d51e3ef0b0c53106d6e4d55946a238d947c17a1d7c0a8f43b63119a6f3aa1063a703d64 SHA512 0e3f53acf90fe142ad677b416d1ee830ad7f7f8a83b80023278ea7d3696ff7af5612379b387b1eb5daae6277a8c30d84c21f0086fe3d8b4b6189f239b1eeb4f8
 DIST libinput-1.13.1.tar.xz 529516 BLAKE2B 9eb9952ca2762470ee3e9ac0eab6b11c4b404b2702cd81b9f0720e539124a8f71a032803cf77105bbdce412b3c5d4a7fee4e24b8d3ceae991bd2ee9b3460e373 SHA512 a19deec802e704038df0901c103a82a3370f56e0299f4cc1b6aa84c1832a66fb638e6f9d0fa708b51df6c3b939cdc1271e4ff547c645c566be03dce0bc9ff7e0
+DIST libinput-1.13.2.tar.xz 529488 BLAKE2B 489f962ca0b0385817fc76a5bc7254143d12c07e32a91dd118dca53fcdd6eaf5d2eef8aa5c5598a2aadda9e4a20b8a4c9340b60dee8286cd322fe2d294f1f6b7 SHA512 26f11c5274c26acc38b9b5729195010c0799a9563f1eb0e0cd67e323f8ed73b0fc8db8584ec8fdf1b726417f64c2daeb54832167079832626c8c1190fccf459f
diff --git a/dev-libs/libinput/libinput-1.13.2.ebuild b/dev-libs/libinput/libinput-1.13.2.ebuild
new file mode 100644 (file)
index 0000000..f8e3130
--- /dev/null
@@ -0,0 +1,81 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit meson python-any-r1 udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/ https://gitlab.freedesktop.org/libinput/libinput"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc input_devices_wacom"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+       input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+       >=dev-libs/libevdev-1.3
+       >=sys-libs/mtdev-1.1
+       virtual/libudev:=
+       virtual/udev
+"
+DEPEND="${RDEPEND}
+       doc? (
+               $(python_gen_any_dep '
+                       dev-python/commonmark[${PYTHON_USEDEP}]
+                       dev-python/recommonmark[${PYTHON_USEDEP}]
+                       dev-python/sphinx[${PYTHON_USEDEP}]
+                       >=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]
+               ')
+               >=app-doc/doxygen-1.8.3
+               >=media-gfx/graphviz-2.38.0
+       )
+"
+#      test? (
+#              >=dev-libs/check-0.9.10
+#              dev-util/valgrind
+#              sys-libs/libunwind )
+BDEPEND="
+       virtual/pkgconfig
+"
+
+python_check_deps() {
+       has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \
+       has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" && \
+       has_version "dev-python/sphinx[${PYTHON_USEDEP}]" && \
+       has_version ">=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+       use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+       # gui can be built but will not be installed
+       local emesonargs=(
+               -Ddebug-gui=false
+               $(meson_use doc documentation)
+               $(meson_use input_devices_wacom libwacom)
+               -Dtests=false # tests are restricted
+               -Dudev-dir="$(get_udevdir)"
+       )
+       meson_src_configure
+}
+
+src_install() {
+       meson_src_install
+       if use doc ; then
+               docinto html
+               dodoc -r "${BUILD_DIR}"/Documentation/.
+       fi
+}
+
+pkg_postinst() {
+       udevadm hwdb --update --root="${ROOT%/}"
+}