dev-libs/libezV24: fix LICENSE, EAPI=7 bump
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Wed, 22 May 2019 16:20:55 +0000 (18:20 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 20 Jul 2019 18:53:20 +0000 (20:53 +0200)
Closes: https://bugs.gentoo.org/686556
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/12082
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-libs/libezV24/files/libezV24-0.1.1-test.patch
dev-libs/libezV24/libezV24-0.1.1-r1.ebuild [new file with mode: 0644]
dev-libs/libezV24/libezV24-0.1.1.ebuild

index f3c2b676546fdc4414bbb1b4a2fdee1ca75fd8fe..425c320365609d95902c195b37474aca5a803fc5 100644 (file)
@@ -4,8 +4,8 @@ RCS file: /cvsroot/ezv24/libezv24/test-v24.c,v
 retrieving revision 1.2
 retrieving revision 1.3
 diff -u -p -r1.2 -r1.3
---- test-v24.c 11 Feb 2003 13:29:43 -0000      1.2
-+++ test-v24.c 13 Oct 2003 07:50:26 -0000      1.3
+--- a/test-v24.c       11 Feb 2003 13:29:43 -0000      1.2
++++ b/test-v24.c       13 Oct 2003 07:50:26 -0000      1.3
 @@ -30,7 +33,11 @@
  #include <string.h>
  #include <signal.h>
diff --git a/dev-libs/libezV24/libezV24-0.1.1-r1.ebuild b/dev-libs/libezV24/libezV24-0.1.1-r1.ebuild
new file mode 100644 (file)
index 0000000..b6b2424
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="library that provides an easy API to Linux serial ports"
+HOMEPAGE="http://ezv24.sourceforge.net"
+SRC_URI="mirror://sourceforge/ezv24/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+HTML_DOCS=( api-html/. )
+
+PATCHES=(
+       "${FILESDIR}"/${P}-build.patch
+       "${FILESDIR}"/${P}-test.patch
+)
+
+src_prepare() {
+       tc-export AR CC RANLIB
+       default
+       sed -i -e 's:__LINUX__:__linux__:' *.c *.h || die
+}
+
+src_install() {
+       export NO_LDCONFIG="stupid"
+       emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" \
+               LIBDIR="${EPREFIX}/usr/$(get_libdir)" install
+       einstalldocs
+}
index db6b724d1f4cac3e85e0b9d649b9f02acb0c1174..30ac27fe8784143b2e49949b66cb7bab2759f83a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=0
@@ -9,7 +9,7 @@ DESCRIPTION="library that provides an easy API to Linux serial ports"
 HOMEPAGE="http://ezv24.sourceforge.net"
 SRC_URI="mirror://sourceforge/ezv24/${P}.tar.gz"
 
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
 SLOT="0"
 KEYWORDS="alpha amd64 ppc sparc x86"
 IUSE=""