sci-visualization/gwyddion: Version bump; fix openexr automagic
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Fri, 24 Jan 2020 04:34:48 +0000 (05:34 +0100)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Fri, 24 Jan 2020 04:35:10 +0000 (05:35 +0100)
Bug: https://bugs.gentoo.org/598682
Closes: https://bugs.gentoo.org/582454
Package-Manager: Portage-2.3.85, Repoman-2.3.20
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
sci-visualization/gwyddion/Manifest
sci-visualization/gwyddion/files/gwyddion-2.55-automagic.patch [new file with mode: 0644]
sci-visualization/gwyddion/gwyddion-2.55.ebuild [new file with mode: 0644]

index 247e6b83c982b84fbb81b73642b8c7b94a884f79..703a0064d39360433b1e5ac11d00b9a39525df94 100644 (file)
@@ -1,2 +1,3 @@
 DIST gwyddion-2.44.tar.xz 3517624 BLAKE2B c32dd33e2fe6c6a09062807db1a25fd54d3becc12bb806a21572f992429cc52a2180221c5627ab49d44f24c13f9928e3825c1b833adff1523d0caa092829ecf7 SHA512 c80a0e4e9dde2f669763629d34dacc0015770c4704a10fc820f4d8e75b4f4275852162653f0c6c52674ed76162861af860de6741466d939066bfea3fb584d2ff
 DIST gwyddion-2.47.tar.xz 3974120 BLAKE2B c9a0241fe509a2f067c16f77d2b02885505d47c3ba0f25a44449e0d5ad05ce8596784392d8f1265823577aeebbab7ad9c96a39625b01bf11da3cebeb1c6453cc SHA512 a6bbda2d32ec013a9d6c7e2b6dbf2cef08d8f964099c0fda511bc92c16c943459f29d52f784a599466af65027aaae3aaeb1b79e56c40e39bc47019044eecd3e6
+DIST gwyddion-2.55.tar.xz 4607560 BLAKE2B 30489d980d3feb6986be4041b59c847673ee589674d5913b4508f28f072eb2f570b98f0b1be01dcf6e1d45e86607582967fd83fe3c859172fcdef3c7bffae741 SHA512 680c33b1f7d36de31274869e7f0af9c06030e04779d6b59f06860ae3f47db4ad45bbf3ee2219bb7b6c01807a807aeafa4f5d0aefe20601e0dda1011acf59fc8e
diff --git a/sci-visualization/gwyddion/files/gwyddion-2.55-automagic.patch b/sci-visualization/gwyddion/files/gwyddion-2.55-automagic.patch
new file mode 100644 (file)
index 0000000..405a255
--- /dev/null
@@ -0,0 +1,33 @@
+diff -ruN gwyddion-2.55.orig/configure.ac gwyddion-2.55/configure.ac
+--- gwyddion-2.55.orig/configure.ac    2019-11-04 10:25:16.000000000 +0100
++++ gwyddion-2.55/configure.ac 2020-01-24 05:22:15.264763441 +0100
+@@ -634,21 +634,25 @@
+ #############################################################################
+ # OpenEXR
+ # Optional.  Used for HDR greyscale OpenEXR pixmap import/export.
+-enable_exr=$have_cxx
+-PKG_CHECK_MODULES(EXR, [OpenEXR],
++GWY_WITH([exr],,[build with OpenEXR support])
++if test "x$enable_exr" != "xno" && "x$have_cxx" != "xno"; then
++  PKG_CHECK_MODULES(EXR, [OpenEXR],
+                   [AC_DEFINE(HAVE_EXR,1,
+                             [Define if we have the OpenEXR package.])],
+                   [enable_exr=no])
++fi
+ AM_CONDITIONAL([HAVE_EXR],[test "x$enable_exr" != xno])
+ #############################################################################
+ # CFITSIO
+ # Optional.  Used for FITS image import.
+-enable_cfitsio=yes
+-PKG_CHECK_MODULES(CFITSIO, [cfitsio],
++GWY_WITH([cfitsio],,[build with cfitsio support])
++if test "x$enable_cfitsio" != "xno"; then
++  PKG_CHECK_MODULES(CFITSIO, [cfitsio],
+                   [AC_DEFINE(HAVE_CFITSIO,1,
+                             [Define if we have the cfitsio package.])],
+                   [enable_cfitsio=no])
++fi
+ AM_CONDITIONAL([HAVE_CFITSIO],[test "x$enable_cfitsio" != xno])
+ #############################################################################
diff --git a/sci-visualization/gwyddion/gwyddion-2.55.ebuild b/sci-visualization/gwyddion/gwyddion-2.55.ebuild
new file mode 100644 (file)
index 0000000..38eb5f9
--- /dev/null
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools gnome2-utils xdg
+
+DESCRIPTION="Framework for Scanning Mode Microscopy data analysis"
+HOMEPAGE="http://gwyddion.net/"
+SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fits gnome nls openexr opengl perl ruby sourceview xml X"
+
+RDEPEND="
+       >=dev-libs/glib-2.32
+       dev-libs/libzip
+       media-libs/libpng:0=
+       >=sci-libs/fftw-3.1:3.0=
+       x11-libs/cairo
+       >=x11-libs/gtk+-2.18:2
+       x11-libs/libXmu
+       x11-libs/pango
+       fits? ( sci-libs/cfitsio )
+       gnome? ( gnome-base/gconf:2 )
+       openexr? ( media-libs/openexr:= )
+       opengl? ( virtual/opengl x11-libs/gtkglext )
+       perl? ( dev-lang/perl:= )
+       ruby? ( dev-ruby/narray )
+       sourceview? ( x11-libs/gtksourceview:2.0 )
+       xml? ( dev-libs/libxml2:2 )"
+
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       doc? ( dev-util/gtk-doc )
+"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-2.55-automagic.patch"
+)
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --disable-rpath \
+               --without-kde4-thumbnailer \
+               $(use_enable doc gtk-doc) \
+               $(use_enable nls) \
+               --disable-pygwy \
+               $(use_with fits cfitsio) \
+               $(use_with perl) \
+               --without-python \
+               $(use_with ruby) \
+               $(use_with opengl gl) \
+               $(use_with openexr exr) \
+               $(use_with sourceview gtksourceview) \
+               $(use_with xml libxml2) \
+               $(use_with X x) \
+               --with-zip=libzip
+}
+
+pkg_postinst() {
+       use gnome && gnome2_gconf_install
+       xdg_pkg_postinst
+}
+
+pkg_prerm() {
+       use gnome && gnome2_gconf_uninstall
+}