sys-apps/portage: Bump to version 2.3.99
authorZac Medico <zmedico@gentoo.org>
Sun, 12 Apr 2020 01:36:47 +0000 (18:36 -0700)
committerZac Medico <zmedico@gentoo.org>
Sun, 12 Apr 2020 01:49:57 +0000 (18:49 -0700)
 #717140 dev-libs/libgit2 upgrade/downgrade loop triggered by
         dev-libs/libgit2-glib dependency on <dev-libs/libgit2-1:0=[ssh]

Bug: https://bugs.gentoo.org/711148
Bug: https://bugs.gentoo.org/717140
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Zac Medico <zmedico@gentoo.org>
sys-apps/portage/Manifest
sys-apps/portage/portage-2.3.99.ebuild [new file with mode: 0644]

index d0676a22eee0bffd1491fcd4ab9ebe5c247356ac..c3ce5f81871349feb5f08a5eddf960dc5533d096 100644 (file)
@@ -3,3 +3,4 @@ DIST portage-2.3.89.tar.bz2 1048621 BLAKE2B 1353f0697a977eb395abd857c8cc43c83991
 DIST portage-2.3.96.tar.bz2 1050446 BLAKE2B 0cb61c70b3ea7557eeeb832ac1dfd3ee9a5cc84a5c9102e18f91fd61f046d738011b563a03203dd96e5164d5949b06945868f908e9c26abcd2971930421fae43 SHA512 4e291cda81cc735375e9e7ca122ec5a7e7f4c626e466c02dd91a0058b7468fedec057e231d5b724b6e111b2853c6c493d824ca385443ef39f8b5776624d3b70e
 DIST portage-2.3.97.tar.bz2 1049544 BLAKE2B 37c5554e3adfb22bf5e11f83645f271cc1b320e7e384cebe120daf9468312b1661c84ed0627aa4ca29f0526af80cb0c0ab6cf43dd7fae78440d2d734b4ad6261 SHA512 2c947146839655ea277867f1aab1527a8361c5ace7a8c767d13d8408e3309b6f5b83059b87c2812702af6e18d39bddbe64e26ff3a59539750dd06e8f6bed40c9
 DIST portage-2.3.98.tar.bz2 1049738 BLAKE2B f312a6e0f7fedee3d4d5948b50aad7dc786e5141a22fa6df9d5d425d76cd094c6e3256460230f8fd6b4261647413a6959578dd5feeda2a966ed5e9046b246d4e SHA512 a9ad1f268479e93f4b197c21db4ff352f96299828593eb34ca678471badbdcb72d6a0e5a62be40b24b84775fbed880d0169d25a4686e0f71805225fe242b6686
+DIST portage-2.3.99.tar.bz2 1051210 BLAKE2B dd3f990dbc87e655a767ce01e1ee3f0b1d5226fa818949408e54b81a2f96e50a4215a79af42b00dc795792858c4f86453b238b14baef4f0793c937b5617534b8 SHA512 176842318a4134ce54c5aa6485fef296f5a14edd2a72421c2011973a0f1a6af39bc5398f1e9eb3b8666d5fc307589c5b91ab93c219bdedb2d307357d8ddefbf5
diff --git a/sys-apps/portage/portage-2.3.99.ebuild b/sys-apps/portage/portage-2.3.99.ebuild
new file mode 100644 (file)
index 0000000..5d75a62
--- /dev/null
@@ -0,0 +1,259 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( pypy3 python3_6 python3_7 python3_8 )
+PYTHON_REQ_USE='bzip2(+),threads(+)'
+
+inherit distutils-r1 linux-info systemd prefix
+
+DESCRIPTION="Portage is the package management and distribution system for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+IUSE="apidoc build doc gentoo-dev +ipc +native-extensions +rsync-verify selinux xattr"
+
+DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
+       >=app-arch/tar-1.27
+       dev-lang/python-exec:2
+       >=sys-apps/sed-4.0.5 sys-devel/patch
+       doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
+       apidoc? (
+               dev-python/sphinx
+               dev-python/sphinx-epytext
+       )"
+# Require sandbox-2.2 for bug #288863.
+# For whirlpool hash, require python[ssl] (bug #425046).
+# For compgen, require bash[readline] (bug #445576).
+# app-portage/gemato goes without PYTHON_USEDEP since we're calling
+# the executable.
+RDEPEND="
+       >=app-arch/tar-1.27
+       dev-lang/python-exec:2
+       !build? (
+               >=sys-apps/sed-4.0.5
+               app-shells/bash:0[readline]
+               >=app-admin/eselect-1.2
+               rsync-verify? (
+                       >=app-portage/gemato-14[${PYTHON_USEDEP}]
+                       >=app-crypt/openpgp-keys-gentoo-release-20180706
+                       >=app-crypt/gnupg-2.2.4-r2[ssl(-)]
+               )
+       )
+       elibc_FreeBSD? ( sys-freebsd/freebsd-bin )
+       elibc_glibc? ( >=sys-apps/sandbox-2.2 )
+       elibc_musl? ( >=sys-apps/sandbox-2.2 )
+       elibc_uclibc? ( >=sys-apps/sandbox-2.2 )
+       kernel_linux? ( sys-apps/util-linux )
+       >=app-misc/pax-utils-0.1.17
+       selinux? ( >=sys-libs/libselinux-2.0.94[python,${PYTHON_USEDEP}] )
+       xattr? ( kernel_linux? (
+               >=sys-apps/install-xattr-0.3
+       ) )
+       !<app-admin/logrotate-3.8.0
+       !<app-portage/gentoolkit-0.4.6
+       !<app-portage/repoman-2.3.10"
+PDEPEND="
+       !build? (
+               >=net-misc/rsync-2.6.4
+               userland_GNU? ( >=sys-apps/coreutils-6.4 )
+       )"
+# coreutils-6.4 rdep is for date format in emerge-webrsync #164532
+# NOTE: FEATURES=installsources requires debugedit and rsync
+
+SRC_ARCHIVES="https://dev.gentoo.org/~zmedico/portage/archives"
+
+prefix_src_archives() {
+       local x y
+       for x in ${@}; do
+               for y in ${SRC_ARCHIVES}; do
+                       echo ${y}/${x}
+               done
+       done
+}
+
+TARBALL_PV=${PV}
+SRC_URI="mirror://gentoo/${PN}-${TARBALL_PV}.tar.bz2
+       $(prefix_src_archives ${PN}-${TARBALL_PV}.tar.bz2)"
+
+pkg_pretend() {
+       local CONFIG_CHECK="~IPC_NS ~PID_NS ~NET_NS"
+
+       check_extra_config
+}
+
+python_prepare_all() {
+       distutils-r1_python_prepare_all
+
+       sed -e "s:^VERSION = \"HEAD\"$:VERSION = \"${PV}\":" -i lib/portage/__init__.py || die
+
+       if use gentoo-dev; then
+               einfo "Disabling --dynamic-deps by default for gentoo-dev..."
+               sed -e 's:\("--dynamic-deps", \)\("y"\):\1"n":' \
+                       -i lib/_emerge/create_depgraph_params.py || \
+                       die "failed to patch create_depgraph_params.py"
+
+               einfo "Enabling additional FEATURES for gentoo-dev..."
+               echo 'FEATURES="${FEATURES} strict-keepdir"' \
+                       >> cnf/make.globals || die
+       fi
+
+       if use native-extensions; then
+               printf "[build_ext]\nportage-ext-modules=true\n" >> \
+                       setup.cfg || die
+       fi
+
+       if ! use ipc ; then
+               einfo "Disabling ipc..."
+               sed -e "s:_enable_ipc_daemon = True:_enable_ipc_daemon = False:" \
+                       -i lib/_emerge/AbstractEbuildProcess.py || \
+                       die "failed to patch AbstractEbuildProcess.py"
+       fi
+
+       if use xattr && use kernel_linux ; then
+               einfo "Adding FEATURES=xattr to make.globals ..."
+               echo -e '\nFEATURES="${FEATURES} xattr"' >> cnf/make.globals \
+                       || die "failed to append to make.globals"
+       fi
+
+       if use build || ! use rsync-verify; then
+               sed -e '/^sync-rsync-verify-metamanifest/s|yes|no|' \
+                       -e '/^sync-webrsync-verify-signature/s|yes|no|' \
+                       -i cnf/repos.conf || die "sed failed"
+       fi
+
+       if [[ -n ${EPREFIX} ]] ; then
+               einfo "Setting portage.const.EPREFIX ..."
+               hprefixify -e "s|^(EPREFIX[[:space:]]*=[[:space:]]*\").*|\1${EPREFIX}\"|" \
+                       -w "/_BINARY/" lib/portage/const.py
+
+               einfo "Prefixing shebangs ..."
+               while read -r -d $'\0' ; do
+                       local shebang=$(head -n1 "$REPLY")
+                       if [[ ${shebang} == "#!"* && ! ${shebang} == "#!${EPREFIX}/"* ]] ; then
+                               sed -i -e "1s:.*:#!${EPREFIX}${shebang:2}:" "$REPLY" || \
+                                       die "sed failed"
+                       fi
+               done < <(find . -type f ! -name etc-update -print0)
+
+               einfo "Adjusting make.globals, repos.conf and etc-update ..."
+               hprefixify cnf/{make.globals,repos.conf} bin/etc-update
+
+               if use prefix-guest ; then
+                       sed -e "s|^\(main-repo = \).*|\\1gentoo_prefix|" \
+                               -e "s|^\\[gentoo\\]|[gentoo_prefix]|" \
+                               -e "s|^\(sync-uri = \).*|\\1rsync://rsync.prefix.bitzolder.nl/gentoo-portage-prefix|" \
+                               -i cnf/repos.conf || die "sed failed"
+               fi
+
+               einfo "Adding FEATURES=force-prefix to make.globals ..."
+               echo -e '\nFEATURES="${FEATURES} force-prefix"' >> cnf/make.globals \
+                       || die "failed to append to make.globals"
+       fi
+
+       cd "${S}/cnf" || die
+       if [ -f "make.conf.example.${ARCH}".diff ]; then
+               patch make.conf.example "make.conf.example.${ARCH}".diff || \
+                       die "Failed to patch make.conf.example"
+       else
+               eerror ""
+               eerror "Portage does not have an arch-specific configuration for this arch."
+               eerror "Please notify the arch maintainer about this issue. Using generic."
+               eerror ""
+       fi
+}
+
+python_compile_all() {
+       local targets=()
+       use doc && targets+=( docbook )
+       use apidoc && targets+=( apidoc )
+
+       if [[ ${targets[@]} ]]; then
+               esetup.py "${targets[@]}"
+       fi
+}
+
+python_test() {
+       esetup.py test
+}
+
+python_install() {
+       # Install sbin scripts to bindir for python-exec linking
+       # they will be relocated in pkg_preinst()
+       distutils-r1_python_install \
+               --system-prefix="${EPREFIX}/usr" \
+               --bindir="$(python_get_scriptdir)" \
+               --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+               --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+               --portage-bindir="${EPREFIX}/usr/lib/portage/${EPYTHON}" \
+               --sbindir="$(python_get_scriptdir)" \
+               --sysconfdir="${EPREFIX}/etc" \
+               "${@}"
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       local targets=()
+       use doc && targets+=(
+               install_docbook
+               --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+       )
+       use apidoc && targets+=(
+               install_apidoc
+               --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+       )
+
+       # install docs
+       if [[ ${targets[@]} ]]; then
+               esetup.py "${targets[@]}"
+       fi
+
+       systemd_dotmpfilesd "${FILESDIR}"/portage-ccache.conf
+
+       # Due to distutils/python-exec limitations
+       # these must be installed to /usr/bin.
+       local sbin_relocations='archive-conf dispatch-conf emaint env-update etc-update fixpackages regenworld'
+       einfo "Moving admin scripts to the correct directory"
+       dodir /usr/sbin
+       for target in ${sbin_relocations}; do
+               einfo "Moving /usr/bin/${target} to /usr/sbin/${target}"
+               mv "${ED}usr/bin/${target}" "${ED}usr/sbin/${target}" || die "sbin scripts move failed!"
+       done
+}
+
+pkg_preinst() {
+       python_setup
+       local sitedir=$(python_get_sitedir)
+       [[ -d ${D%/}${sitedir} ]] || die "${D%/}${sitedir}: No such directory"
+       env -u DISTDIR \
+               -u PORTAGE_OVERRIDE_EPREFIX \
+               -u PORTAGE_REPOSITORIES \
+               -u PORTDIR \
+               -u PORTDIR_OVERLAY \
+               PYTHONPATH="${D%/}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
+               "${PYTHON}" -m portage._compat_upgrade.default_locations || die
+
+       # elog dir must exist to avoid logrotate error for bug #415911.
+       # This code runs in preinst in order to bypass the mapping of
+       # portage:portage to root:root which happens after src_install.
+       keepdir /var/log/portage/elog
+       # This is allowed to fail if the user/group are invalid for prefix users.
+       if chown portage:portage "${ED}"var/log/portage{,/elog} 2>/dev/null ; then
+               chmod g+s,ug+rwx "${ED}"var/log/portage{,/elog}
+       fi
+
+       if has_version "<${CATEGORY}/${PN}-2.3.77"; then
+               elog "The emerge --autounmask option is now disabled by default, except for"
+               elog "portions of behavior which are controlled by the --autounmask-use and"
+               elog "--autounmask-license options. For backward compatibility, previous"
+               elog "behavior of --autounmask=y and --autounmask=n is entirely preserved."
+               elog "Users can get the old behavior simply by adding --autounmask to the"
+               elog "make.conf EMERGE_DEFAULT_OPTS variable. For the rationale for this"
+               elog "change, see https://bugs.gentoo.org/658648."
+       fi
+}