net-mail/dovecot: bump to 2.3.10
authorEray Aslan <eras@gentoo.org>
Mon, 9 Mar 2020 08:26:30 +0000 (11:26 +0300)
committerEray Aslan <eras@gentoo.org>
Mon, 9 Mar 2020 08:26:30 +0000 (11:26 +0300)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Eray Aslan <eras@gentoo.org>
net-mail/dovecot/Manifest
net-mail/dovecot/dovecot-2.3.10.ebuild [new file with mode: 0644]

index 46a90a2acd29c8f953e6b399b58e7bee13c2c7f1..ae1ac2f905d068a21f6fc8e3191a17925751ce6c 100644 (file)
@@ -1,6 +1,8 @@
 DIST dovecot-2.2-pigeonhole-0.4.24.2.tar.gz 1833284 BLAKE2B bee45fd129aee3d5126bd48b27829e7e266a5c1043411b6b23655bbf32e2f684763b82bff476a954bf7f0c7aae4e038c0892be70776726c7b324e409a8f89d78 SHA512 a51de88bcbac83ced7d314a560bd44f119dd80bf58f350da522501f072c0a4c02ff8c11152e2b858f14bb8ca9a9b665960cbe37a0c8ef4600b430e65ddbf3bf4
 DIST dovecot-2.2.36.4.tar.gz 6257899 BLAKE2B 3260e96f369e85f2dfd5ece0d9b12902c7192d057369e8a151cc6ab7b4f2033d4e1029fb862d412f2837fd384d7fe729cf1ab15cac9ac335e943bb1fdb532b51 SHA512 e33ab2f6c5f7b4ffca3d57580329f1df8e1655c755a1a6b575a4e49d57ea94d1ab67df2419033c9d68acf5959c6edfa596815dc2bc43798e9aef3d17d271cc4d
+DIST dovecot-2.3-pigeonhole-0.5.10.tar.gz 1899237 BLAKE2B a308500d6a51d4a9b99ae16b75829f1f799351675a31d91e450c4ea1b095d7719af424534f4b7736559b06819a337e7be0bd44307b77a775c8a54359e41822c1 SHA512 f3d380edba4d25d20ee52db21d2965e3a6b229924e9a04fbf45cfe32e1d25448977ee41b12ba41ad8cf8b795f19bb1dbef1d7d09e775598d782123268f61dc8b
 DIST dovecot-2.3-pigeonhole-0.5.7.2.tar.gz 1857602 BLAKE2B 8de6200bb1ca99d25b48c963c007e9fda07e21f0708d4542e497985a61c07270febd8f29171d607c4025f4651c2ef17d84447a789ebad896c55aa36ec2cd876c SHA512 7fc8d89ee31c8e8c16a9aeaeffb591f4188de36fc80e3a30a9ae10bc5acd7ea5d5d91e077fda566e61d588d9221ec53044ce17a9cc0c9c219dbe6824558a1d60
 DIST dovecot-2.3-pigeonhole-0.5.9.tar.gz 1897060 BLAKE2B 73b9abd0a7ea9468f7880fdd0d0471c5825f341c7297807c404ce50a8792f821d2599840ce9eb2705a118a0ee078aafad9f4f6eb64a02fbcb3b0f89c00042ada SHA512 1b8d2ac8d3985dde035fc45df519788a924ba971f3e39717f5196ea56a982d4156226586d0a964473525d086967883ea52f2e624e81f7035cb0952b76f2414d8
+DIST dovecot-2.3.10.tar.gz 7222241 BLAKE2B 4ffc95c3a52c9287603d19fb91fbc8418d4c37bbc82f30e5026eb5888705a07fc1903b0571d4b4cb1c8ca74bf373acc931129803ca2ad91cb085e92a483a684c SHA512 73e10d7d1e616d6599eb53f2d2d1ac0f0f2e6e84019faac5cd525e833da44839a7e483635b61d432e3254a9e5f6f90915bec8940c584210341085241949dffa2
 DIST dovecot-2.3.7.2.tar.gz 7076231 BLAKE2B 2cb93aa594db722489063b490469dfe284b1f997b64c9a699b506ccbd04e8e7c2d503ddc12a2598958dfca88560c19487801a728f386b8fea5f637a75b83812e SHA512 172f7f0edb884259e4c050607510aee67a35c3a20b7dd147e7c8a25a04921c18f7d6b5c85af2c69ae8c4d53791550970e471b033dbfae94253e331053b6a317d
 DIST dovecot-2.3.9.3.tar.gz 7181682 BLAKE2B 3ef9c50ea2b9d2f8a5d953e373baaf5d880ae4c93dbe773ce267784ded207fb338959a334aa12a449f8d39eb51284318de317d8953a56a0f7f016199769be809 SHA512 e39dc825a03f009928b67d01747bb70487fbec155e6be5109037db67b78301aa761db432f7355e96d927abf30c68f0116a5f2cf518b9eebf7f5c7806ac00ae41
diff --git a/net-mail/dovecot/dovecot-2.3.10.ebuild b/net-mail/dovecot/dovecot-2.3.10.ebuild
new file mode 100644 (file)
index 0000000..097bc5b
--- /dev/null
@@ -0,0 +1,286 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# do not add a ssl USE flag.  ssl is mandatory
+SSL_DEPS_SKIP=1
+inherit autotools ssl-cert systemd toolchain-funcs
+
+MY_P="${P/_/.}"
+#MY_S="${PN}-ce-${PV}"
+major_minor="$(ver_cut 1-2)"
+sieve_version="0.5.10"
+if [[ ${PV} == *_rc* ]] ; then
+       rc_dir="rc/"
+else
+       rc_dir=""
+fi
+SRC_URI="https://dovecot.org/releases/${major_minor}/${rc_dir}${MY_P}.tar.gz
+       sieve? (
+       https://pigeonhole.dovecot.org/releases/${major_minor}/${rc_dir}${PN}-${major_minor}-pigeonhole-${sieve_version}.tar.gz
+       )
+       managesieve? (
+       https://pigeonhole.dovecot.org/releases/${major_minor}/${rc_dir}${PN}-${major_minor}-pigeonhole-${sieve_version}.tar.gz
+       ) "
+DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
+HOMEPAGE="https://www.dovecot.org/"
+
+SLOT="0"
+LICENSE="LGPL-2.1 MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+IUSE_DOVECOT_AUTH="kerberos ldap lua mysql pam postgres sqlite vpopmail"
+IUSE_DOVECOT_COMPRESS="bzip2 lzma lz4 zlib"
+IUSE_DOVECOT_OTHER="argon2 caps doc ipv6 libressl lucene managesieve selinux sieve solr static-libs suid tcpd textcat"
+
+IUSE="${IUSE_DOVECOT_AUTH} ${IUSE_DOVECOT_COMPRESS} ${IUSE_DOVECOT_OTHER}"
+
+DEPEND="argon2? ( dev-libs/libsodium )
+       bzip2? ( app-arch/bzip2 )
+       caps? ( sys-libs/libcap )
+       kerberos? ( virtual/krb5 )
+       ldap? ( net-nds/openldap )
+       lua? ( dev-lang/lua:* )
+       lucene? ( >=dev-cpp/clucene-2.3 )
+       lzma? ( app-arch/xz-utils )
+       lz4? ( app-arch/lz4 )
+       mysql? ( dev-db/mysql-connector-c:0= )
+       pam? ( sys-libs/pam )
+       postgres? ( dev-db/postgresql:* !dev-db/postgresql[ldap,threads] )
+       selinux? ( sec-policy/selinux-dovecot )
+       solr? ( net-misc/curl dev-libs/expat )
+       sqlite? ( dev-db/sqlite:* )
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
+       suid? ( acct-group/mail )
+       tcpd? ( sys-apps/tcp-wrappers )
+       textcat? ( app-text/libexttextcat )
+       vpopmail? ( net-mail/vpopmail )
+       zlib? ( sys-libs/zlib )
+       virtual/libiconv
+       dev-libs/icu:="
+
+RDEPEND="${DEPEND}
+       acct-group/dovecot
+       acct-group/dovenull
+       acct-user/dovecot
+       acct-user/dovenull
+       net-mail/mailbase"
+
+pkg_setup() {
+       if use managesieve && ! use sieve; then
+               ewarn "managesieve USE flag selected but sieve USE flag unselected"
+               ewarn "sieve USE flag will be turned on"
+       fi
+}
+
+src_prepare() {
+       default
+       # bug 657108
+       elibtoolize
+       #eautoreconf
+}
+
+src_configure() {
+       local conf=""
+
+       if use postgres || use mysql || use sqlite; then
+               conf="${conf} --with-sql"
+       fi
+
+       # turn valgrind tests off. Bug #340791
+       VALGRIND=no econf \
+               --with-rundir="${EPREFIX}/run/dovecot" \
+               --with-statedir="${EPREFIX}/var/lib/dovecot" \
+               --with-moduledir="${EPREFIX}/usr/$(get_libdir)/dovecot" \
+               --without-stemmer \
+               --disable-rpath \
+               --without-libbsd \
+               --with-icu \
+               --with-ssl \
+               --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+               $( use_with argon2 sodium ) \
+               $( use_with bzip2 bzlib ) \
+               $( use_with caps libcap ) \
+               $( use_with kerberos gssapi ) \
+               $( use_with lua ) \
+               $( use_with ldap ) \
+               $( use_with lucene ) \
+               $( use_with lz4 ) \
+               $( use_with lzma ) \
+               $( use_with mysql ) \
+               $( use_with pam ) \
+               $( use_with postgres pgsql ) \
+               $( use_with sqlite ) \
+               $( use_with solr ) \
+               $( use_with tcpd libwrap ) \
+               $( use_with textcat ) \
+               $( use_with vpopmail ) \
+               $( use_with zlib ) \
+               $( use_enable static-libs static ) \
+               ${conf}
+
+       if use sieve || use managesieve ; then
+               # The sieve plugin needs this file to be build to determine the plugin
+               # directory and the list of libraries to link to.
+               emake dovecot-config
+               cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+               econf \
+                       $( use_enable static-libs static ) \
+                       --localstatedir="${EPREFIX}/var" \
+                       --enable-shared \
+                       --with-dovecot="${S}" \
+                       $( use_with managesieve )
+       fi
+}
+
+src_compile() {
+       default
+       if use sieve || use managesieve ; then
+               cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+               emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+       fi
+}
+
+src_test() {
+       default
+       if use sieve || use managesieve ; then
+               cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+               default
+       fi
+}
+
+src_install() {
+       default
+
+       # insecure:
+       # use suid && fperms u+s /usr/libexec/dovecot/deliver
+       # better:
+       if use suid;then
+               einfo "Changing perms to allow deliver to be suided"
+               fowners root:mail "/usr/libexec/dovecot/dovecot-lda"
+               fperms 4750 "/usr/libexec/dovecot/dovecot-lda"
+       fi
+
+       newinitd "${FILESDIR}"/dovecot.init-r6 dovecot
+
+       rm -rf "${ED}"/usr/share/doc/dovecot
+
+       dodoc AUTHORS NEWS README TODO
+       dodoc doc/*.{txt,cnf,xml,sh}
+       docinto example-config
+       dodoc doc/example-config/*.{conf,ext}
+       docinto example-config/conf.d
+       dodoc doc/example-config/conf.d/*.{conf,ext}
+       docinto wiki
+       dodoc doc/wiki/*
+       doman doc/man/*.{1,7}
+
+       # Create the dovecot.conf file from the dovecot-example.conf file that
+       # the dovecot folks nicely left for us....
+       local conf="${ED}/etc/dovecot/dovecot.conf"
+       local confd="${ED}/etc/dovecot/conf.d"
+
+       insinto /etc/dovecot
+       doins doc/example-config/*.{conf,ext}
+       insinto /etc/dovecot/conf.d
+       doins doc/example-config/conf.d/*.{conf,ext}
+       fperms 0600 /etc/dovecot/dovecot-{ldap,sql}.conf.ext
+       rm -f "${confd}/../README"
+
+       # .maildir is the Gentoo default
+       local mail_location="maildir:~/.maildir"
+       sed -i -e \
+               "s|#mail_location =|mail_location = ${mail_location}|" \
+               "${confd}/10-mail.conf" \
+               || die "failed to update mail location settings in 10-mail.conf"
+
+       # We're using pam files (imap and pop3) provided by mailbase
+       if use pam; then
+               sed -i -e '/driver = pam/,/^[ \t]*}/ s|#args = dovecot|args = "\*"|' \
+                       "${confd}/auth-system.conf.ext" \
+                       || die "failed to update PAM settings in auth-system.conf.ext"
+               # mailbase does not provide a sieve pam file
+               use managesieve && dosym imap /etc/pam.d/sieve
+               sed -i -e \
+                       's/#!include auth-system.conf.ext/!include auth-system.conf.ext/' \
+                       "${confd}/10-auth.conf" \
+                       || die "failed to update PAM settings in 10-auth.conf"
+       fi
+
+       # Disable ipv6 if necessary
+       if ! use ipv6; then
+               sed -i -e 's/^#listen = \*, ::/listen = \*/g' "${conf}" \
+                       || die "failed to update listen settings in dovecot.conf"
+       fi
+
+       # Update ssl cert locations
+       sed -i -e 's:^#ssl = yes:ssl = yes:' "${confd}/10-ssl.conf" \
+               || die "ssl conf failed"
+       sed -i -e 's:^ssl_cert =.*:ssl_cert = </etc/ssl/dovecot/server.pem:' \
+               -e 's:^ssl_key =.*:ssl_key = </etc/ssl/dovecot/server.key:' \
+               "${confd}/10-ssl.conf" || die "failed to update SSL settings in 10-ssl.conf"
+
+       # Install SQL configuration
+       if use mysql || use postgres; then
+               sed -i -e \
+                       's/#!include auth-sql.conf.ext/!include auth-sql.conf.ext/' \
+                       "${confd}/10-auth.conf" || die "failed to update SQL settings in \
+                       10-auth.conf"
+       fi
+
+       # Install LDAP configuration
+       if use ldap; then
+               sed -i -e \
+                       's/#!include auth-ldap.conf.ext/!include auth-ldap.conf.ext/' \
+                       "${confd}/10-auth.conf" \
+                       || die "failed to update ldap settings in 10-auth.conf"
+       fi
+
+       if use vpopmail; then
+               sed -i -e \
+                       's/#!include auth-vpopmail.conf.ext/!include auth-vpopmail.conf.ext/' \
+                       "${confd}/10-auth.conf" \
+                       || die "failed to update vpopmail settings in 10-auth.conf"
+       fi
+
+       if use sieve || use managesieve ; then
+               cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+               emake DESTDIR="${ED}" install
+               sed -i -e \
+                       's/^[[:space:]]*#mail_plugins = $mail_plugins/mail_plugins = sieve/' "${confd}/15-lda.conf" \
+                       || die "failed to update sieve settings in 15-lda.conf"
+               rm -rf "${ED}"/usr/share/doc/dovecot
+               docinto example-config/conf.d
+               dodoc doc/example-config/conf.d/*.conf
+               insinto /etc/dovecot/conf.d
+               doins doc/example-config/conf.d/90-sieve{,-extprograms}.conf
+               use managesieve && doins doc/example-config/conf.d/20-managesieve.conf
+               docinto sieve/rfc
+               dodoc doc/rfc/*.txt
+               docinto sieve/devel
+               dodoc doc/devel/DESIGN
+               docinto plugins
+               dodoc doc/plugins/*.txt
+               docinto extensions
+               dodoc doc/extensions/*.txt
+               docinto locations
+               dodoc doc/locations/*.txt
+               doman doc/man/*.{1,7}
+       fi
+
+       use static-libs || find "${ED}"/usr/lib* -name '*.la' -delete
+}
+
+pkg_postinst() {
+       # Let's not make a new certificate if we already have one
+       if ! [[ -e "${ROOT}"/etc/ssl/dovecot/server.pem && \
+               -e "${ROOT}"/etc/ssl/dovecot/server.key ]];     then
+               einfo "Creating SSL     certificate"
+               SSL_ORGANIZATION="${SSL_ORGANIZATION:-Dovecot IMAP Server}"
+               install_cert /etc/ssl/dovecot/server
+       fi
+
+       elog "Please read https://wiki2.dovecot.org/Upgrading/ for upgrade notes."
+}