x11-misc/xdg-utils: Make a 1.1.3_p20200220 snap
authorMichał Górny <mgorny@gentoo.org>
Sun, 3 May 2020 05:54:17 +0000 (07:54 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 3 May 2020 06:28:03 +0000 (08:28 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
x11-misc/xdg-utils/Manifest
x11-misc/xdg-utils/xdg-utils-1.1.3_p20200220.ebuild [new file with mode: 0644]

index d1b2a49514100d2c5d807a19844582a3c645c951..267f0faf07d62ea6ae459bfa0731d8e01b482a35 100644 (file)
@@ -1 +1,2 @@
 DIST xdg-utils-1.1.3.tar.gz 297170 BLAKE2B bd281df73d8c966d11b502dd7ec88d96dbc9683503f54b043ae4842f146b6847bd3dd6902cf993771848d9fcb55d26d67f032af2b8aa0795a6d9855535e57d5b SHA512 d1f819a211eb4104a90dfdc6fedcb640fd46b15ccfc8762266f8f538c49d74cb00027b8c1af991fb2a200acb4379986ae375700e06a2aa08fb41a38f883acb3e
+DIST xdg-utils-1.1.3_p20200220.tar.bz2 287080 BLAKE2B eb9067527d5073f290d10ad36bcda24d4b813f3c98776b57955a7f254956795c26f1536c858ac104259f68f755746976d2cfc3aeccb9b9b35eaca5ea5eb89806 SHA512 8445109e87fb9e92edeebbf6b07a41b79344bc5016eb7224f5f2b7e599c6d075363337c81dd2ddf8f3007c633debba7f814631188c02db3ae002f622b4c323ec
diff --git a/x11-misc/xdg-utils/xdg-utils-1.1.3_p20200220.ebuild b/x11-misc/xdg-utils/xdg-utils-1.1.3_p20200220.ebuild
new file mode 100644 (file)
index 0000000..2df4bb6
--- /dev/null
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+EGIT_COMMIT="9816ebb3e6fd9f23e993b8b7fcbd56f92d9c9197"
+DESCRIPTION="Portland utils for cross-platform/cross-toolkit/cross-desktop interoperability"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/xdg-utils/"
+SRC_URI="
+       https://gitlab.freedesktop.org/xdg/xdg-utils/-/archive/${EGIT_COMMIT}/${P}.tar.bz2"
+S=${WORKDIR}/xdg-utils-${EGIT_COMMIT}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos ~x64-solaris"
+IUSE="doc"
+
+RDEPEND="
+       dev-util/desktop-file-utils
+       dev-perl/File-MimeInfo
+       dev-perl/Net-DBus
+       dev-perl/X11-Protocol
+       sys-apps/dbus
+       x11-misc/shared-mime-info
+       x11-apps/xprop
+       x11-apps/xset
+"
+BDEPEND=">=app-text/xmlto-0.0.26-r1[text(+)]"
+
+DOCS=( ChangeLog README RELEASE_NOTES TODO )
+
+# Tests run random system programs, including interactive programs
+# that block forever
+RESTRICT="test"
+
+src_prepare() {
+       default
+       # If you choose to do git snapshot instead of patchset, you need to remember
+       # to run `autoconf` in ./ and `make scripts-clean` in ./scripts/ to refresh
+       # all the files
+       eautoreconf
+}
+
+src_configure() {
+       export ac_cv_path_XMLTO="$(type -P xmlto) --skip-validation" #502166
+       default
+       emake -C scripts scripts-clean
+}
+
+src_install() {
+       default
+
+       newdoc scripts/xsl/README README.xsl
+       use doc && dodoc -r scripts/html
+
+       # Install default XDG_DATA_DIRS, bug #264647
+       echo XDG_DATA_DIRS=\"${EPREFIX}/usr/local/share\" > 30xdg-data-local
+       echo 'COLON_SEPARATED="XDG_DATA_DIRS XDG_CONFIG_DIRS"' >> 30xdg-data-local
+       doenvd 30xdg-data-local
+
+       echo XDG_DATA_DIRS=\"${EPREFIX}/usr/share\" > 90xdg-data-base
+       echo XDG_CONFIG_DIRS=\"${EPREFIX}/etc/xdg\" >> 90xdg-data-base
+       doenvd 90xdg-data-base
+}
+
+pkg_postinst() {
+       [[ -x $(type -P gtk-update-icon-cache) ]] \
+               || elog "Install dev-util/gtk-update-icon-cache for the gtk-update-icon-cache command."
+}