games-kids/gcompris: bump to 0.95
authorVirgil Dupras <vdupras@gentoo.org>
Mon, 24 Dec 2018 13:29:04 +0000 (08:29 -0500)
committerVirgil Dupras <vdupras@gentoo.org>
Mon, 24 Dec 2018 13:33:19 +0000 (08:33 -0500)
Closes: https://bugs.gentoo.org/634268
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.52, Repoman-2.3.11

games-kids/gcompris/Manifest
games-kids/gcompris/gcompris-0.95.ebuild [new file with mode: 0644]

index 83be08b77ac12051ba43126015a508f52ec0b71a..77930db83d99fa0ff477b4dc77a2bf245ddf1680 100644 (file)
@@ -1 +1,2 @@
 DIST gcompris-qt-0.91.tar.xz 70681140 BLAKE2B 6f392eb5065afe8239ef99ba12d0fdcdedc9e0bb4ec16fd9acfa17c6597b495cf7153095fc4fb07c0eb9f7e0aae1f51888157c84b846cfd0112ab2a3465e3ecf SHA512 bc4515acc5c58869997e44c0c3c38d2904f34a7a5efede1ee7aefcbd1ae5907fe00b29a3ecf8e5e46396031736d10df64523e280dfffe3bac2df7e34fe9a8eda
+DIST gcompris-qt-0.95.tar.xz 73113640 BLAKE2B cb46ca38f1e0cfab44409b0986b35e5afa2588a027c22bb925bb1d516406118b638968660c2d73cfbb88d9b950abf19a693592286980ac5207adeafe50eb85a1 SHA512 c62057371b11e295541a4e074fcb8826543e498dca486ae26c739135345187754dfc2a30a00a20a212de250df6e4bc412bcf66bffc8dc5263501e6c3d30efa03
diff --git a/games-kids/gcompris/gcompris-0.95.ebuild b/games-kids/gcompris/gcompris-0.95.ebuild
new file mode 100644 (file)
index 0000000..a4bf361
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils desktop
+
+DESCRIPTION="full featured educational application for children from 2 to 10"
+HOMEPAGE="https://gcompris.net/"
+SRC_URI="http://gcompris.net/download/qt/src/gcompris-qt-${PV}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}-qt-${PV}"
+
+RDEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtgraphicaleffects:5
+       dev-qt/qtgui:5
+       dev-qt/qtmultimedia:5[qml]
+       dev-qt/qtnetwork:5
+       dev-qt/qtquickcontrols:5
+       dev-qt/qtsensors:5[qml]
+       dev-qt/qtsvg:5
+       dev-qt/qtxml:5
+       dev-qt/qtxmlpatterns:5"
+DEPEND="${RDEPEND}
+       dev-qt/linguist-tools"
+
+src_configure() {
+       local mycmakeargs=(
+               # TODO: add box2d support
+               -DQML_BOX2D_MODULE=disabled
+       )
+       cmake-utils_src_configure
+}
+
+src_install() {
+       cmake-utils_src_install
+       domenu org.kde.gcompris.desktop
+}